{"cve":"CVE-2025-57106","nvd":{"published":"2025-10-31T15:15:42.317","modified":"2026-06-17T09:42:51.747","status":"Analyzed","description":"Kitware VTK (Visualization Toolkit) up to 9.5.0 is vulnerable to Buffer Overflow in vtkGLTFDocumentLoader. The vulnerability occurs in the BufferDataExtractionWorker template function when processing GLTF accessor data.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","score":7.5},"cwes":["CWE-122"],"references":["https://gitlab.kitware.com/vtk/vtk/-/issues/19733","https://gitlab.kitware.com/vtk/vtk/-/issues/19734"],"products":["vtk:vtk"],"source":"nvd","synced_at":"2026-10-19T22:14:53.307938015+00:00"},"epss":{"cve":"CVE-2025-57106","score":0.00429,"percentile":0.37208,"date":"2026-10-31"},"kev":null,"osv":[{"id":"PYSEC-2025-224","url":"https://osv.dev/vulnerability/PYSEC-2025-224","summary":"","modified":"2026-05-20T09:19:21.712041Z","packages":[{"ecosystem":"PyPI","name":"vtk","purl":"pkg:pypi/vtk","ranges":["<9.5.1"],"fixed":["9.5.1"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}