{"cve":"CVE-2025-55675","nvd":{"published":"2025-08-14T14:15:34.953","modified":"2026-06-17T09:41:59.830","status":"Modified","description":"Apache Superset contains an improper access control vulnerability in its /explore endpoint. A missing authorization check allows an authenticated user to discover metadata about datasources they do not have permission to access. By iterating through the datasource_id in the URL, an attacker can enumerate and confirm the existence and names of protected datasources, leading to sensitive information disclosure.\n\nThis issue affects Apache Superset: before 5.0.0.\n\nUsers are recommended to upgrade to version 5.0.0, which fixes the issue.","cvss_v4":{"vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N","score":5.3},"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","score":6.5},"cwes":["CWE-285"],"references":["https://lists.apache.org/thread/op681b4kbd7g84tfjf9omz0sxggbcv33","http://www.openwall.com/lists/oss-security/2025/08/14/6"],"products":["apache:superset"],"source":"nvd","synced_at":"2026-10-19T22:06:45.861874017+00:00"},"epss":{"cve":"CVE-2025-55675","score":0.006,"percentile":0.48736,"date":"2026-11-01"},"kev":null,"osv":[{"id":"GHSA-mhpq-m962-mg92","url":"https://osv.dev/vulnerability/GHSA-mhpq-m962-mg92","summary":"Apache Superset allows authenticated users to discover metadata about datasources they don't have permission to access","modified":"2026-09-10T03:50:27.204771411Z","packages":[{"ecosystem":"PyPI","name":"apache-superset","purl":"pkg:pypi/apache-superset","ranges":["<5.0.0"],"fixed":["5.0.0"]}]},{"id":"PYSEC-2026-1186","url":"https://osv.dev/vulnerability/PYSEC-2026-1186","summary":"Apache Superset allows authenticated users to discover metadata about datasources they don't have permission to access","modified":"2026-07-07T17:56:29.327044811Z","packages":[{"ecosystem":"PyPI","name":"apache-superset","purl":"pkg:pypi/apache-superset","ranges":["<5.0.0"],"fixed":["5.0.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}