{"cve":"CVE-2025-53622","nvd":{"published":"2025-07-15T15:15:25.680","modified":"2026-06-17T09:38:35.390","status":"Deferred","description":"DSpace open source software is a repository application which provides durable access to digital resources. Prior to versions 7.6.4, 8.2, and 9.1, a path traversal vulnerability is possible during the import of an archive (in Simple Archive Format), either from command-line (`./dspace import` command) or from the \"Batch Import (Zip)\" user interface feature. An attacker may craft a malicious Simple Archive Format (SAF) package where the `contents` file references any system files (using relative traversal sequences) which are readable by the Tomcat user.  If such a package is imported, this will result in sensitive content disclose, including retrieving arbitrary files or configurations from the server where DSpace is running. The Simple Archive Format (SAF) importer / Batch Import (Zip) is only usable by site administrators (from user interface / REST API) or system administrators (from command-line). Therefore, to exploit this vulnerability, the malicious payload would have to be provided by an attacker and trusted by an administrator (who would trigger the import). The fix is included in DSpace 7.6.4, 8.2 and 9.1. For those who cannot upgrade immediately, it is possible to manually patch the DSpace backend. (No changes are necessary to the frontend.)  A pull request exists which can be used to patch systems running DSpace 7.6.x, 8.x or 9.0. Although it is not possible to fully protect the system via workarounds, one may can apply a best practice. Administrators must carefully inspect any SAF archives (they did not construct themselves) before importing, paying close attention to the `contents` file to validate it does not reference files outside of the SAF archives.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:N/A:L","score":5.2},"cwes":["CWE-22"],"references":["https://github.com/DSpace/DSpace/pull/11036","https://github.com/DSpace/DSpace/pull/11036.patch","https://github.com/DSpace/DSpace/pull/11037","https://github.com/DSpace/DSpace/pull/11037.patch","https://github.com/DSpace/DSpace/pull/11038"],"products":[],"source":"nvd","synced_at":"2026-10-19T22:04:28.436527499+00:00"},"epss":{"cve":"CVE-2025-53622","score":0.0048,"percentile":0.41432,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-vhvx-8xgc-99wf","url":"https://osv.dev/vulnerability/GHSA-vhvx-8xgc-99wf","summary":"DSpace is vulnerable to Path Traversal attacks when importing packages using Simple Archive Format","modified":"2025-07-15T19:27:23.897032Z","packages":[{"ecosystem":"Maven","name":"org.dspace:dspace-api","purl":"pkg:maven/org.dspace/dspace-api","ranges":["<7.6.4"],"fixed":["7.6.4"]},{"ecosystem":"Maven","name":"org.dspace:dspace-api","purl":"pkg:maven/org.dspace/dspace-api","ranges":[">=8.0 <8.2"],"fixed":["8.2"]},{"ecosystem":"Maven","name":"org.dspace:dspace-api","purl":"pkg:maven/org.dspace/dspace-api","ranges":[">=9.0 <9.1"],"fixed":["9.1"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}