{"cve":"CVE-2025-53506","nvd":{"published":"2025-07-10T20:15:26.970","modified":"2026-06-17T09:38:20.783","status":"Modified","description":"Uncontrolled Resource Consumption vulnerability in Apache Tomcat if an HTTP/2 client did not acknowledge the initial settings frame that reduces the maximum permitted concurrent streams.\n\nThis issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.8, from 10.1.0-M1 through 10.1.42, from 9.0.0.M1 through 9.0.106.\nThe following versions were EOL at the time the CVE was created but are \nknown to be affected: 8.5.0 through 8.5.100. Other EOL versions may also be affected.\n\n\nUsers are recommended to upgrade to version 11.0.9, 10.1.43 or 9.0.107, which fix the issue.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","score":7.5},"cwes":["CWE-400"],"references":["https://lists.apache.org/thread/p09775q0rd185m6zz98krg0fp45j8kr0","http://www.openwall.com/lists/oss-security/2025/07/10/13","https://lists.debian.org/debian-lts-announce/2025/07/msg00009.html"],"products":["apache:tomcat"],"source":"nvd","synced_at":"2026-10-19T22:04:28.436527499+00:00"},"epss":{"cve":"CVE-2025-53506","score":0.02129,"percentile":0.81948,"date":"2026-11-01"},"kev":null,"osv":[{"id":"GHSA-25xr-qj8w-c4vf","url":"https://osv.dev/vulnerability/GHSA-25xr-qj8w-c4vf","summary":"Apache Tomcat Coyote vulnerable to Denial of Service via excessive HTTP/2 streams","modified":"2026-09-10T03:50:25.989583964Z","packages":[{"ecosystem":"Maven","name":"org.apache.tomcat:tomcat-coyote","purl":"pkg:maven/org.apache.tomcat/tomcat-coyote","ranges":[">=11.0.0-M1 <11.0.9"],"fixed":["11.0.9"]},{"ecosystem":"Maven","name":"org.apache.tomcat:tomcat-coyote","purl":"pkg:maven/org.apache.tomcat/tomcat-coyote","ranges":[">=10.1.0-M1 <10.1.43"],"fixed":["10.1.43"]},{"ecosystem":"Maven","name":"org.apache.tomcat:tomcat-coyote","purl":"pkg:maven/org.apache.tomcat/tomcat-coyote","ranges":[">=9.0.0.M1 <9.0.107"],"fixed":["9.0.107"]},{"ecosystem":"Maven","name":"org.apache.tomcat:tomcat-coyote","purl":"pkg:maven/org.apache.tomcat/tomcat-coyote","ranges":[">=8.5.0 <=8.5.100"],"fixed":[]},{"ecosystem":"Maven","name":"org.apache.tomcat.embed:tomcat-embed-core","purl":"pkg:maven/org.apache.tomcat.embed/tomcat-embed-core","ranges":[">=8.5.0 <=8.5.100"],"fixed":[]},{"ecosystem":"Maven","name":"org.apache.tomcat.embed:tomcat-embed-core","purl":"pkg:maven/org.apache.tomcat.embed/tomcat-embed-core","ranges":[">=9.0.0.M1 <9.0.107"],"fixed":["9.0.107"]},{"ecosystem":"Maven","name":"org.apache.tomcat.embed:tomcat-embed-core","purl":"pkg:maven/org.apache.tomcat.embed/tomcat-embed-core","ranges":[">=10.1.0-M1 <10.1.43"],"fixed":["10.1.43"]},{"ecosystem":"Maven","name":"org.apache.tomcat.embed:tomcat-embed-core","purl":"pkg:maven/org.apache.tomcat.embed/tomcat-embed-core","ranges":[">=11.0.0-M1 <11.0.9"],"fixed":["11.0.9"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}