{"cve":"CVE-2025-50460","nvd":{"published":"2025-08-01T16:15:41.600","modified":"2026-06-17T09:35:04.847","status":"Deferred","description":"A remote code execution (RCE) vulnerability exists in the ms-swift project version 3.3.0 due to unsafe deserialization in tests/run.py using yaml.load() from the PyYAML library (versions = 5.3.1). If an attacker can control the content of the YAML configuration file passed to the --run_config parameter, arbitrary code can be executed during deserialization. This can lead to full system compromise. The vulnerability is triggered when a malicious YAML file is loaded, allowing the execution of arbitrary Python commands such as os.system(). It is recommended to upgrade PyYAML to version 5.4 or higher, and to use yaml.safe_load() to mitigate the issue.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","score":9.8},"cwes":["CWE-502"],"references":["https://github.com/Anchor0221/CVE-2025-50460","https://github.com/advisories/GHSA-6757-jp84-gxfx","https://github.com/modelscope/ms-swift","https://github.com/modelscope/ms-swift/blob/main/tests/run.py#L420","https://github.com/Anchor0221/CVE-2025-50460"],"products":[],"source":"nvd","synced_at":"2026-10-19T22:05:46.678065081+00:00"},"epss":{"cve":"CVE-2025-50460","score":0.02686,"percentile":0.85853,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-fm6c-f59h-7mmg","url":"https://osv.dev/vulnerability/GHSA-fm6c-f59h-7mmg","summary":"MS SWIFT Remote Code Execution via unsafe PyYAML deserialization","modified":"2026-07-07T17:57:29.103679620Z","packages":[{"ecosystem":"PyPI","name":"ms-swift","purl":"pkg:pypi/ms-swift","ranges":["<=3.6.3"],"fixed":[]}]},{"id":"PYSEC-2026-1683","url":"https://osv.dev/vulnerability/PYSEC-2026-1683","summary":"MS SWIFT Remote Code Execution via unsafe PyYAML deserialization","modified":"2026-07-07T17:47:17.742699310Z","packages":[{"ecosystem":"PyPI","name":"ms-swift","purl":"pkg:pypi/ms-swift","ranges":["<=3.6.3"],"fixed":[]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}