{"cve":"CVE-2025-48924","nvd":{"published":"2025-07-11T15:15:24.347","modified":"2026-06-17T09:30:29.473","status":"Modified","description":"Uncontrolled Recursion vulnerability in Apache Commons Lang.\n\nThis issue affects Apache Commons Lang: Starting with commons-lang:commons-lang 2.0 to 2.6, and, from org.apache.commons:commons-lang3 3.0 before 3.18.0.\n\nThe methods ClassUtils.getClass(...) can throw StackOverflowError on very long inputs. Because an Error is usually not handled by applications and libraries, a \nStackOverflowError could cause an application to stop.\n\nUsers are recommended to upgrade to version 3.18.0, which fixes the issue.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L","score":5.3},"cwes":["CWE-674"],"references":["https://lists.apache.org/thread/bgv0lpswokgol11tloxnjfzdl7yrc1g1","http://www.openwall.com/lists/oss-security/2025/07/11/1","https://lists.debian.org/debian-lts-announce/2025/08/msg00000.html","https://lists.debian.org/debian-lts-announce/2025/08/msg00026.html","https://lists.debian.org/debian-lts-announce/2025/09/msg00032.html"],"products":["apache:commons_lang"],"source":"nvd","synced_at":"2026-10-19T22:04:28.436527499+00:00"},"epss":{"cve":"CVE-2025-48924","score":0.02632,"percentile":0.85533,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-j288-q9x7-2f5v","url":"https://osv.dev/vulnerability/GHSA-j288-q9x7-2f5v","summary":"Apache Commons Lang is vulnerable to Uncontrolled Recursion when processing long inputs","modified":"2026-09-10T03:50:26.176912270Z","packages":[{"ecosystem":"Maven","name":"org.apache.commons:commons-lang3","purl":"pkg:maven/org.apache.commons/commons-lang3","ranges":[">=3.0 <3.18.0"],"fixed":["3.18.0"]},{"ecosystem":"Maven","name":"commons-lang:commons-lang","purl":"pkg:maven/commons-lang/commons-lang","ranges":[">=2.0 <=2.6"],"fixed":[]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}