{"cve":"CVE-2025-48734","nvd":{"published":"2025-05-28T14:15:34.070","modified":"2026-06-17T09:30:14.797","status":"Modified","description":"Improper Access Control vulnerability in Apache Commons.\n\n\n\nA special BeanIntrospector class was added in version 1.9.2. This can be used to stop attackers from using the declared class property of Java enum objects to get access to the classloader. However this protection was not enabled by default. PropertyUtilsBean (and consequently BeanUtilsBean) now disallows declared class level property access by default.\n\n\n\n\n\nReleases 1.11.0 and 2.0.0-M2 address a potential security issue when accessing enum properties in an uncontrolled way. If an application using Commons BeanUtils passes property paths from an external source directly to the getProperty() method of PropertyUtilsBean, an attacker can access the enum’s class loader via the “declaredClass” property available on all Java “enum” objects. Accessing the enum’s “declaredClass” allows remote attackers to access the ClassLoader and execute arbitrary code. The same issue exists with PropertyUtilsBean.getNestedProperty().\nStarting in versions 1.11.0 and 2.0.0-M2 a special BeanIntrospector suppresses the “declaredClass” property. Note that this new BeanIntrospector is enabled by default, but you can disable it to regain the old behavior; see section 2.5 of the user's guide and the unit tests.\n\nThis issue affects Apache Commons BeanUtils 1.x before 1.11.0, and 2.x before 2.0.0-M2.Users of the artifact commons-beanutils:commons-beanutils\n\n 1.x are recommended to upgrade to version 1.11.0, which fixes the issue.\n\n\nUsers of the artifact org.apache.commons:commons-beanutils2\n\n 2.x are recommended to upgrade to version 2.0.0-M2, which fixes the issue.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","score":8.8},"cwes":["CWE-284"],"references":["https://lists.apache.org/thread/s0hb3jkfj5f3ryx6c57zqtfohb0of1g9","http://www.openwall.com/lists/oss-security/2025/05/28/6","https://lists.debian.org/debian-lts-announce/2025/06/msg00027.html"],"products":["apache:commons_beanutils"],"source":"nvd","synced_at":"2026-10-19T22:01:57.636215869+00:00"},"epss":{"cve":"CVE-2025-48734","score":0.02018,"percentile":0.80933,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-wxr5-93ph-8wr9","url":"https://osv.dev/vulnerability/GHSA-wxr5-93ph-8wr9","summary":"Apache Commons Improper Access Control vulnerability","modified":"2026-09-10T03:50:24.755642299Z","packages":[{"ecosystem":"Maven","name":"commons-beanutils:commons-beanutils","purl":"pkg:maven/commons-beanutils/commons-beanutils","ranges":[">=1.0 <1.11.0"],"fixed":["1.11.0"]},{"ecosystem":"Maven","name":"org.apache.commons:commons-beanutils2","purl":"pkg:maven/org.apache.commons/commons-beanutils2","ranges":[">=2.0.0-M1 <2.0.0-M2"],"fixed":["2.0.0-M2"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}