{"cve":"CVE-2025-31722","nvd":{"published":"2025-04-02T15:15:59.680","modified":"2026-06-17T09:10:50.070","status":"Analyzed","description":"In Jenkins Templating Engine Plugin 2.5.3 and earlier, libraries defined in folders are not subject to sandbox protection, allowing attackers with Item/Configure permission to execute arbitrary code in the context of the Jenkins controller JVM.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","score":8.8},"cwes":["CWE-94"],"references":["https://www.jenkins.io/security/advisory/2025-04-02/#SECURITY-3505"],"products":["jenkins:templating_engine"],"source":"nvd","synced_at":"2026-10-19T22:00:57.946988208+00:00"},"epss":{"cve":"CVE-2025-31722","score":0.0131,"percentile":0.70649,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-4vjp-327p-w4qv","url":"https://osv.dev/vulnerability/GHSA-4vjp-327p-w4qv","summary":"Jenkins Templating Engine Plugin Vulnerable to Arbitrary Code Execution","modified":"2025-04-02T23:12:09.287758Z","packages":[{"ecosystem":"Maven","name":"org.jenkins-ci.plugins:templating-engine","purl":"pkg:maven/org.jenkins-ci.plugins/templating-engine","ranges":["<2.5.4"],"fixed":["2.5.4"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}