{"cve":"CVE-2025-31650","nvd":{"published":"2025-04-28T20:15:20.653","modified":"2026-06-17T09:10:43.967","status":"Modified","description":"Improper Input Validation vulnerability in Apache Tomcat. Incorrect error handling for some invalid HTTP priority headers resulted in incomplete clean-up of the failed request which created a memory leak. A large number of such requests could trigger an OutOfMemoryException resulting in a denial of service.\n\nThis issue affects Apache Tomcat: from 9.0.76 through 9.0.102, from 10.1.10 through 10.1.39, from 11.0.0-M2 through 11.0.5.\nThe following versions were EOL at the time the CVE was created but are \nknown to be affected: 8.5.90 though 8.5.100.\n\n\nUsers are recommended to upgrade to version 9.0.104, 10.1.40 or 11.0.6 which fix the issue.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","score":7.5},"cwes":["CWE-459"],"references":["https://lists.apache.org/thread/j6zzk0y3yym9pzfzkq5vcyxzz0yzh826","http://www.openwall.com/lists/oss-security/2025/04/28/2","https://lists.debian.org/debian-lts-announce/2025/07/msg00009.html"],"products":["apache:tomcat"],"source":"nvd","synced_at":"2026-10-19T22:01:11.054312287+00:00"},"epss":{"cve":"CVE-2025-31650","score":0.61322,"percentile":0.99163,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-3p2h-wqq4-wf4h","url":"https://osv.dev/vulnerability/GHSA-3p2h-wqq4-wf4h","summary":"Apache Tomcat Denial of Service via invalid HTTP priority header","modified":"2026-09-10T03:50:57.424635503Z","packages":[{"ecosystem":"Maven","name":"org.apache.tomcat:tomcat-coyote","purl":"pkg:maven/org.apache.tomcat/tomcat-coyote","ranges":[">=9.0.76 <9.0.104"],"fixed":["9.0.104"]},{"ecosystem":"Maven","name":"org.apache.tomcat:tomcat-coyote","purl":"pkg:maven/org.apache.tomcat/tomcat-coyote","ranges":[">=10.1.10 <10.1.40"],"fixed":["10.1.40"]},{"ecosystem":"Maven","name":"org.apache.tomcat:tomcat-coyote","purl":"pkg:maven/org.apache.tomcat/tomcat-coyote","ranges":[">=11.0.0-M2 <11.0.6"],"fixed":["11.0.6"]},{"ecosystem":"Maven","name":"org.apache.tomcat.embed:tomcat-embed-core","purl":"pkg:maven/org.apache.tomcat.embed/tomcat-embed-core","ranges":[">=9.0.76 <9.0.104"],"fixed":["9.0.104"]},{"ecosystem":"Maven","name":"org.apache.tomcat.embed:tomcat-embed-core","purl":"pkg:maven/org.apache.tomcat.embed/tomcat-embed-core","ranges":[">=10.1.10 <10.1.40"],"fixed":["10.1.40"]},{"ecosystem":"Maven","name":"org.apache.tomcat.embed:tomcat-embed-core","purl":"pkg:maven/org.apache.tomcat.embed/tomcat-embed-core","ranges":[">=11.0.0-M2 <11.0.6"],"fixed":["11.0.6"]},{"ecosystem":"Maven","name":"org.apache.tomcat:tomcat-coyote","purl":"pkg:maven/org.apache.tomcat/tomcat-coyote","ranges":[">=8.5.0 <=8.5.100"],"fixed":[]},{"ecosystem":"Maven","name":"org.apache.tomcat.embed:tomcat-embed-core","purl":"pkg:maven/org.apache.tomcat.embed/tomcat-embed-core","ranges":[">=8.5.0 <=8.5.100"],"fixed":[]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}