{"cve":"CVE-2025-30217","nvd":{"published":"2025-03-26T17:15:26.740","modified":"2026-06-17T09:08:22.540","status":"Analyzed","description":"Frappe is a full-stack web application framework. Prior to versions 14.93.2 and 15.55.0, a SQL Injection vulnerability has been identified in Frappe Framework which could allow a malicious actor to access sensitive information. Versions 14.93.2 and 15.55.0 contain a patch for the issue. No known workarounds are available.","cvss_v4":{"vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:U","score":6.6},"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","score":7.5},"cwes":["CWE-89"],"references":["https://github.com/frappe/frappe/security/advisories/GHSA-6phg-4wmq-h5h3"],"products":["frappe:frappe"],"source":"nvd","synced_at":"2026-10-19T22:00:28.034033815+00:00"},"epss":{"cve":"CVE-2025-30217","score":0.00368,"percentile":0.30669,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-6phg-4wmq-h5h3","url":"https://osv.dev/vulnerability/GHSA-6phg-4wmq-h5h3","summary":"Frappe has possibility of SQL injection due to improper validations","modified":"2026-07-07T17:57:26.684961114Z","packages":[{"ecosystem":"PyPI","name":"frappe","purl":"pkg:pypi/frappe","ranges":["<14.93.2"],"fixed":["14.93.2"]},{"ecosystem":"PyPI","name":"frappe","purl":"pkg:pypi/frappe","ranges":[">=15.0.0 <15.55.0"],"fixed":["15.55.0"]}]},{"id":"PYSEC-2026-1391","url":"https://osv.dev/vulnerability/PYSEC-2026-1391","summary":"Frappe has possibility of SQL injection due to improper validations","modified":"2026-07-07T17:47:21.868106496Z","packages":[{"ecosystem":"PyPI","name":"frappe","purl":"pkg:pypi/frappe","ranges":["<14.93.2",">=15.0.0 <15.55.0"],"fixed":["14.93.2","15.55.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}