{"cve":"CVE-2025-29927","nvd":{"published":"2025-03-21T15:15:42.660","modified":"2026-06-17T09:05:53.640","status":"Analyzed","description":"Next.js is a React framework for building full-stack web applications. Starting in version 1.11.4 and prior to versions 12.3.5, 13.5.9, 14.2.25, and 15.2.3, it is possible to bypass authorization checks within a Next.js application, if the authorization check occurs in middleware. If patching to a safe version is infeasible, it is recommend that you prevent external user requests which contain the x-middleware-subrequest header from reaching your Next.js application. This vulnerability is fixed in 12.3.5, 13.5.9, 14.2.25, and 15.2.3.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N","score":9.1},"cwes":["CWE-863","CWE-285"],"references":["https://github.com/vercel/next.js/commit/52a078da3884efe6501613c7834a3d02a91676d2","https://github.com/vercel/next.js/commit/5fd3ae8f8542677c6294f32d18022731eab6fe48","https://github.com/vercel/next.js/releases/tag/v12.3.5","https://github.com/vercel/next.js/releases/tag/v13.5.9","https://github.com/vercel/next.js/security/advisories/GHSA-f82v-jwr5-mffw"],"products":["vercel:next.js"],"source":"nvd","synced_at":"2026-10-19T22:00:28.034033815+00:00"},"epss":{"cve":"CVE-2025-29927","score":0.99225,"percentile":0.99936,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-f82v-jwr5-mffw","url":"https://osv.dev/vulnerability/GHSA-f82v-jwr5-mffw","summary":"Authorization Bypass in Next.js Middleware","modified":"2026-09-10T03:50:23.209773204Z","packages":[{"ecosystem":"npm","name":"next","purl":"pkg:npm/next","ranges":[">=13.0.0 <13.5.9"],"fixed":["13.5.9"]},{"ecosystem":"npm","name":"next","purl":"pkg:npm/next","ranges":[">=14.0.0 <14.2.25"],"fixed":["14.2.25"]},{"ecosystem":"npm","name":"next","purl":"pkg:npm/next","ranges":[">=15.0.0 <15.2.3"],"fixed":["15.2.3"]},{"ecosystem":"npm","name":"next","purl":"pkg:npm/next","ranges":[">=12.0.0 <12.3.5"],"fixed":["12.3.5"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}