{"cve":"CVE-2025-29891","nvd":{"published":"2025-03-12T15:15:40.997","modified":"2026-06-17T09:05:50.273","status":"Analyzed","description":"Bypass/Injection vulnerability in Apache Camel.\n\nThis issue affects Apache Camel: from 4.10.0 before 4.10.2, from 4.8.0 before 4.8.5, from 3.10.0 before 3.22.4.\n\nUsers are recommended to upgrade to version 4.10.2 for 4.10.x LTS, 4.8.5 for 4.8.x LTS and 3.22.4 for 3.x releases.\n\nThis vulnerability is present in Camel's default incoming header filter, that allows an attacker to include Camel specific headers that for some Camel components can alter the behaviours such as the camel-bean component, or the camel-exec component.\n\nIf you have Camel applications that are directly connected to the internet via HTTP, then an attacker could include parameters in the HTTP requests that are sent to the Camel application that get translated into headers. \n\nThe headers could be both provided as request parameters for an HTTP methods invocation or as part of the payload of the HTTP methods invocation.\n\nAll the known Camel HTTP component such as camel-servlet, camel-jetty, camel-undertow, camel-platform-http, and camel-netty-http would be vulnerable out of the box.\n\nThis CVE is related to the CVE-2025-27636: while they have the same root cause and are fixed with the same fix, CVE-2025-27636 was assumed to only be exploitable if an attacker could add malicious HTTP headers, while we have now determined that it is also exploitable via HTTP parameters. Like in CVE-2025-27636, exploitation is only possible if the Camel route uses particular vulnerable components.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:L","score":4.8},"cwes":["CWE-164"],"references":["https://camel.apache.org/security/CVE-2025-27636.html","https://camel.apache.org/security/CVE-2025-29891.html","https://github.com/akamai/CVE-2025-27636-Apache-Camel-PoC"],"products":["apache:camel"],"source":"nvd","synced_at":"2026-10-19T22:00:17.429720821+00:00"},"epss":{"cve":"CVE-2025-29891","score":0.76087,"percentile":0.99532,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-96v5-c2h5-56hm","url":"https://osv.dev/vulnerability/GHSA-96v5-c2h5-56hm","summary":"Apache Camel Message Header Injection through request parameters","modified":"2025-03-19T15:58:36.862904Z","packages":[{"ecosystem":"Maven","name":"org.apache.camel:camel-support","purl":"pkg:maven/org.apache.camel/camel-support","ranges":[">=3.10.0 <3.22.4"],"fixed":["3.22.4"]},{"ecosystem":"Maven","name":"org.apache.camel:camel-support","purl":"pkg:maven/org.apache.camel/camel-support","ranges":[">=4.9.0 <4.10.2"],"fixed":["4.10.2"]},{"ecosystem":"Maven","name":"org.apache.camel:camel-support","purl":"pkg:maven/org.apache.camel/camel-support","ranges":[">=4.0.0-M1 <4.8.5"],"fixed":["4.8.5"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}