{"cve":"CVE-2025-27819","nvd":{"published":"2025-06-10T08:15:22.687","modified":"2026-06-17T09:04:16.633","status":"Analyzed","description":"In CVE-2023-25194, we announced the RCE/Denial of service attack via SASL JAAS JndiLoginModule configuration in Kafka Connect API. But not only Kafka Connect API is vulnerable to this attack, the Apache Kafka brokers also have this vulnerability. To exploit this vulnerability, the attacker needs to be able to connect to the Kafka cluster and have the AlterConfigs permission on the cluster resource.\n\n\nSince Apache Kafka 3.4.0, we have added a system property (\"-Dorg.apache.kafka.disallowed.login.modules\") to disable the problematic login modules usage in SASL JAAS configuration. Also by default \"com.sun.security.auth.module.JndiLoginModule\" is disabled in Apache Kafka 3.4.0, and \"com.sun.security.auth.module.JndiLoginModule,com.sun.security.auth.module.LdapLoginModule\" is disabled by default in in Apache Kafka 3.9.1/4.0.0","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","score":7.5},"cwes":["CWE-502"],"references":["https://kafka.apache.org/cve-list"],"products":["apache:kafka"],"source":"nvd","synced_at":"2026-10-19T22:02:23.998251710+00:00"},"epss":{"cve":"CVE-2025-27819","score":0.0103,"percentile":0.63712,"date":"2026-11-01"},"kev":null,"osv":[{"id":"GHSA-mcwh-c9pg-xw43","url":"https://osv.dev/vulnerability/GHSA-mcwh-c9pg-xw43","summary":"Apache Kafka Deserialization of Untrusted Data vulnerability","modified":"2025-12-11T21:01:12.235418Z","packages":[{"ecosystem":"Maven","name":"org.apache.kafka:kafka_2.10","purl":"pkg:maven/org.apache.kafka/kafka_2.10","ranges":["all versions"],"fixed":[]},{"ecosystem":"Maven","name":"org.apache.kafka:kafka_2.11","purl":"pkg:maven/org.apache.kafka/kafka_2.11","ranges":["all versions"],"fixed":[]},{"ecosystem":"Maven","name":"org.apache.kafka:kafka_2.12","purl":"pkg:maven/org.apache.kafka/kafka_2.12","ranges":["<3.4.0"],"fixed":["3.4.0"]},{"ecosystem":"Maven","name":"org.apache.kafka:kafka_2.13","purl":"pkg:maven/org.apache.kafka/kafka_2.13","ranges":["<3.4.0"],"fixed":["3.4.0"]},{"ecosystem":"Maven","name":"org.apache.kafka:kafka_2.8.0","purl":"pkg:maven/org.apache.kafka/kafka_2.8.0","ranges":["all versions"],"fixed":[]},{"ecosystem":"Maven","name":"org.apache.kafka:kafka_2.8.2","purl":"pkg:maven/org.apache.kafka/kafka_2.8.2","ranges":["all versions"],"fixed":[]},{"ecosystem":"Maven","name":"org.apache.kafka:kafka_2.9.1","purl":"pkg:maven/org.apache.kafka/kafka_2.9.1","ranges":["all versions"],"fixed":[]},{"ecosystem":"Maven","name":"org.apache.kafka:kafka_2.9.2","purl":"pkg:maven/org.apache.kafka/kafka_2.9.2","ranges":["all versions"],"fixed":[]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}