{"cve":"CVE-2025-26803","nvd":{"published":"2025-02-24T16:15:15.020","modified":"2026-06-17T09:02:27.333","status":"Analyzed","description":"The http parser in Phusion Passenger 6.0.21 through 6.0.25 before 6.0.26 allows a denial of service during parsing of a request with an invalid HTTP method.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","score":7.5},"cwes":["CWE-908"],"references":["https://blog.phusion.nl/2025/02/19/passenger-6-0-26/","https://github.com/phusion/passenger/commit/bb15591646687064ab2d578d5f9660b2a4168017","https://github.com/phusion/passenger/compare/release-6.0.25...release-6.0.26","https://github.com/phusion/passenger/releases/tag/release-6.0.26","https://www.phusionpassenger.com/support"],"products":["phusion:passenger"],"source":"nvd","synced_at":"2026-10-19T21:59:48.811064707+00:00"},"epss":{"cve":"CVE-2025-26803","score":0.00617,"percentile":0.49589,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-2cj2-qqxj-5m3r","url":"https://osv.dev/vulnerability/GHSA-2cj2-qqxj-5m3r","summary":"Phusion Passenger denial of service ","modified":"2025-03-02T07:59:16.557898Z","packages":[{"ecosystem":"RubyGems","name":"passenger","purl":"pkg:gem/passenger","ranges":[">=6.0.21 <6.0.26"],"fixed":["6.0.26"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}