{"cve":"CVE-2025-26467","nvd":{"published":"2025-08-25T14:15:30.103","modified":"2026-06-17T09:01:51.007","status":"Analyzed","description":"Privilege Defined With Unsafe Actions vulnerability in Apache Cassandra. An user with MODIFY permission ON ALL KEYSPACES can escalate privileges to superuser within a targeted Cassandra cluster via unsafe actions to a system resource. Operators granting data MODIFY permission on all keyspaces on affected versions should review data access rules for potential breaches.\n\n\n\nThis issue affects Apache Cassandra 3.0.30, 3.11.17, 4.0.16, 4.1.7, 5.0.2, but this advisory is only for 4.0.16 because the fix to CVE-2025-23015 was incorrectly applied to 4.0.16, so that version is still affected.\n\nUsers in the 4.0 series are recommended to upgrade to version 4.0.17 which fixes the issue. Users from 3.0, 3.11, 4.1 and 5.0 series should follow recommendation from CVE-2025-23015.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","score":8.8},"cwes":["CWE-267"],"references":["https://lists.apache.org/thread/xxj36rr4d6mzyqpld05dn8b9951hfpz7"],"products":["apache:cassandra"],"source":"nvd","synced_at":"2026-10-19T22:07:46.309729541+00:00"},"epss":{"cve":"CVE-2025-26467","score":0.00515,"percentile":0.43878,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-5c4f-pxmx-xcm4","url":"https://osv.dev/vulnerability/GHSA-5c4f-pxmx-xcm4","summary":"Apache Cassandra: User with MODIFY permission on ALL KEYSPACES can escalate privileges to superuser via unsafe actions (4.0.16 only)","modified":"2025-08-27T09:42:09.447589Z","packages":[{"ecosystem":"Maven","name":"org.apache.cassandra:cassandra-all","purl":"pkg:maven/org.apache.cassandra/cassandra-all","ranges":[">=4.0.16 <4.0.17"],"fixed":["4.0.17"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}