{"cve":"CVE-2025-24876","nvd":{"published":"2025-02-11T01:15:11.887","modified":"2026-06-17T08:59:46.653","status":"Deferred","description":"The SAP Approuter Node.js package version v16.7.1 and before is vulnerable to Authentication bypass. When trading an authorization code an attacker can steal the session of the victim by injecting malicious payload causing High impact on confidentiality and integrity of the application","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N","score":8.1},"cwes":["CWE-302","CWE-1287"],"references":["https://me.sap.com/notes/3567974","https://url.sap/sapsecuritypatchday","https://www.npmjs.com/package/@sap/approuter?activeTab=versions"],"products":[],"source":"nvd","synced_at":"2026-10-19T21:59:18.731010617+00:00"},"epss":{"cve":"CVE-2025-24876","score":0.00495,"percentile":0.4253,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-cpfx-964w-4jvp","url":"https://osv.dev/vulnerability/GHSA-cpfx-964w-4jvp","summary":"Authentication bypass in @sap/approuter","modified":"2025-02-11T16:56:59.985625Z","packages":[{"ecosystem":"npm","name":"@sap/approuter","purl":"pkg:npm/%40sap/approuter","ranges":[">=2.6.1 <16.7.2"],"fixed":["16.7.2"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}