{"cve":"CVE-2025-24854","nvd":{"published":"2025-07-31T09:15:27.650","modified":"2026-06-17T08:59:44.347","status":"Modified","description":"A carefully crafted request using the Image plugin could trigger an XSS \nvulnerability on Apache JSPWiki, which could allow the attacker to \nexecute javascript in the victim's browser and get some sensitive \ninformation about the victim.\n\n\n\n\n\nApache JSPWiki users should upgrade to 2.12.3 or later.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","score":6.1},"cwes":["CWE-79"],"references":["https://jspwiki-wiki.apache.org/Wiki.jsp?page=CVE-2025-24854","http://www.openwall.com/lists/oss-security/2025/07/30/3"],"products":["apache:jspwiki"],"source":"nvd","synced_at":"2026-10-19T22:05:46.678065081+00:00"},"epss":{"cve":"CVE-2025-24854","score":0.00475,"percentile":0.41055,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-72ww-4rcw-mc62","url":"https://osv.dev/vulnerability/GHSA-72ww-4rcw-mc62","summary":"Apache JSPWiki Cross-Site Scripting (XSS) Vulnerability in the Image Plugin","modified":"2025-11-05T20:52:18.587689Z","packages":[{"ecosystem":"Maven","name":"org.apache.jspwiki:jspwiki-main","purl":"pkg:maven/org.apache.jspwiki/jspwiki-main","ranges":["<2.12.3"],"fixed":["2.12.3"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}