{"cve":"CVE-2025-24839","nvd":{"published":"2025-04-16T08:15:13.987","modified":"2026-06-17T08:59:41.667","status":"Analyzed","description":"Mattermost versions 10.5.x <= 10.5.1, 10.4.x <= 10.4.3, 9.11.x <= 9.11.9 fail to prevent Wrangler posts from triggering AI responses. This vulnerability allows users without access to the AI bot to activate it by attaching the activate_ai override property to a post via the Wrangler plugin, provided both the AI and Wrangler plugins are enabled.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N","score":4.3},"cwes":["CWE-863"],"references":["https://mattermost.com/security-updates"],"products":["mattermost:mattermost_server"],"source":"nvd","synced_at":"2026-10-19T22:01:11.054312287+00:00"},"epss":{"cve":"CVE-2025-24839","score":0.00226,"percentile":0.13315,"date":"2026-11-01"},"kev":null,"osv":[{"id":"GHSA-j639-m367-75cf","url":"https://osv.dev/vulnerability/GHSA-j639-m367-75cf","summary":"Mattermost Incorrect Authorization vulnerability","modified":"2026-09-10T03:50:57.239682651Z","packages":[{"ecosystem":"Go","name":"github.com/mattermost/mattermost/server/v8","purl":"pkg:golang/github.com/mattermost/mattermost/server/v8","ranges":[">=10.5.0 <10.5.2"],"fixed":["10.5.2"]},{"ecosystem":"Go","name":"github.com/mattermost/mattermost/server/v8","purl":"pkg:golang/github.com/mattermost/mattermost/server/v8","ranges":[">=10.4.0 <10.4.4"],"fixed":["10.4.4"]},{"ecosystem":"Go","name":"github.com/mattermost/mattermost/server/v8","purl":"pkg:golang/github.com/mattermost/mattermost/server/v8","ranges":[">=9.11.0 <9.11.10"],"fixed":["9.11.10"]},{"ecosystem":"Go","name":"github.com/mattermost/mattermost/server/v8","purl":"pkg:golang/github.com/mattermost/mattermost/server/v8","ranges":["<8.0.0-20250314142426-c049748b8863"],"fixed":["8.0.0-20250314142426-c049748b8863"]}]},{"id":"GO-2025-3621","url":"https://osv.dev/vulnerability/GO-2025-3621","summary":"Mattermost Incorrect Authorization vulnerability in github.com/mattermost/mattermost-server","modified":"2026-02-04T02:15:43.822333Z","packages":[{"ecosystem":"Go","name":"github.com/mattermost/mattermost-server","purl":"pkg:golang/github.com/mattermost/mattermost-server","ranges":[">=9.11.0+incompatible <9.11.10+incompatible",">=10.4.0+incompatible <10.4.4+incompatible",">=10.5.0+incompatible <10.5.2+incompatible"],"fixed":["9.11.10+incompatible","10.4.4+incompatible","10.5.2+incompatible"]},{"ecosystem":"Go","name":"github.com/mattermost/mattermost-server/v5","purl":"pkg:golang/github.com/mattermost/mattermost-server/v5","ranges":["all versions"],"fixed":[]},{"ecosystem":"Go","name":"github.com/mattermost/mattermost-server/v6","purl":"pkg:golang/github.com/mattermost/mattermost-server/v6","ranges":["all versions"],"fixed":[]},{"ecosystem":"Go","name":"github.com/mattermost/mattermost/server/v8","purl":"pkg:golang/github.com/mattermost/mattermost/server/v8","ranges":["<8.0.0-20250218121836-2b5275d87136"],"fixed":["8.0.0-20250218121836-2b5275d87136"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}