{"cve":"CVE-2025-24814","nvd":{"published":"2025-01-27T09:15:14.947","modified":"2026-06-17T08:59:39.810","status":"Analyzed","description":"Core creation allows users to replace \"trusted\" configset files with arbitrary configuration\n\nSolr instances that (1) use the \"FileSystemConfigSetService\" component (the default in \"standalone\" or \"user-managed\" mode), and (2) are running without authentication and authorization are vulnerable to a sort of privilege escalation wherein individual \"trusted\" configset files can be ignored in favor of potentially-untrusted replacements available elsewhere on the filesystem.  These replacement config files are treated as \"trusted\" and can use \"<lib>\" tags to add to Solr's classpath, which an attacker might use to load malicious code as a searchComponent or other plugin.\n\nThis issue affects all Apache Solr versions up through Solr 9.7.  Users can protect against the vulnerability by enabling authentication and authorization on their Solr clusters or switching to SolrCloud (and away from \"FileSystemConfigSetService\").  Users are also recommended to upgrade to Solr 9.8.0, which mitigates this issue by disabling use of \"<lib>\" tags by default.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:L","score":5.5},"cwes":["CWE-250"],"references":["https://lists.apache.org/thread/gl291pn8x9f9n52ys5l0pc0b6qtf0qw1","http://www.openwall.com/lists/oss-security/2025/01/26/1","https://security.netapp.com/advisory/ntap-20250214-0002/"],"products":["apache:solr"],"source":"nvd","synced_at":"2026-10-19T21:58:41.599736885+00:00"},"epss":{"cve":"CVE-2025-24814","score":0.01169,"percentile":0.67403,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-68r2-fwcg-qpm8","url":"https://osv.dev/vulnerability/GHSA-68r2-fwcg-qpm8","summary":"Apache Solr vulnerable to Execution with Unnecessary Privileges","modified":"2026-09-10T03:50:56.344694649Z","packages":[{"ecosystem":"Maven","name":"org.apache.solr:solr-core","purl":"pkg:maven/org.apache.solr/solr-core","ranges":["<9.8.0"],"fixed":["9.8.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}