{"cve":"CVE-2025-12967","nvd":{"published":"2025-11-10T18:16:06.043","modified":"2026-10-18T21:10:00.120","status":"Deferred","description":"An issue in AWS Wrappers for Amazon Aurora PostgreSQL may allow for privilege escalation to rds_superuser role. A low privilege authenticated user can create a crafted function that could be executed with permissions of other Amazon Relational Database Service (RDS) users.\n\nWe recommend customers upgrade to the following versions: AWS JDBC Wrapper to v2.6.5, AWS Go Wrapper to 2025-10-17, AWS NodeJS Wrapper to v2.0.1, AWS Python Wrapper to v1.4.0 and AWS PGSQL ODBC driver to v1.0.1","cvss_v4":{"vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","score":8.6},"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H","score":8.0},"cwes":["CWE-470"],"references":["https://aws.amazon.com/security/security-bulletins/AWS-2025-028/","https://github.com/aws/aws-advanced-go-wrapper/releases/tag/release-2025-10-17","https://github.com/aws/aws-advanced-go-wrapper/security/advisories/GHSA-7wq2-32h4-9hc9","https://github.com/aws/aws-advanced-jdbc-wrapper/releases/tag/2.6.5","https://github.com/aws/aws-advanced-jdbc-wrapper/security/advisories/GHSA-7xw4-g7mm-r4hh"],"products":[],"source":"nvd","synced_at":"2026-10-19T22:14:53.307938015+00:00"},"epss":{"cve":"CVE-2025-12967","score":0.00782,"percentile":0.55711,"date":"2026-10-25"},"kev":null,"osv":[{"id":"GHSA-4jvf-wx3f-2x8q","url":"https://osv.dev/vulnerability/GHSA-4jvf-wx3f-2x8q","summary":"AWS Advanced Python Wrapper: Privilege Escalation in Aurora PostgreSQL instance ","modified":"2026-07-07T17:57:19.328087872Z","packages":[{"ecosystem":"PyPI","name":"aws-advanced-python-wrapper","purl":"pkg:pypi/aws-advanced-python-wrapper","ranges":["<1.4.0"],"fixed":["1.4.0"]}]},{"id":"PYSEC-2026-1205","url":"https://osv.dev/vulnerability/PYSEC-2026-1205","summary":"AWS Advanced Python Wrapper: Privilege Escalation in Aurora PostgreSQL instance ","modified":"2026-07-07T17:46:32.809717645Z","packages":[{"ecosystem":"PyPI","name":"aws-advanced-python-wrapper","purl":"pkg:pypi/aws-advanced-python-wrapper","ranges":["<1.4.0"],"fixed":["1.4.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}