{"cve":"CVE-2024-9148","nvd":{"published":"2024-09-25T01:15:49.297","modified":"2026-06-17T08:24:03.130","status":"Analyzed","description":"Flowise < 2.1.1 suffers from a Stored Cross-Site vulnerability due to a lack of input sanitization in Flowise Chat Embed < 2.0.0.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","score":6.1},"cwes":["CWE-79"],"references":["https://www.tenable.com/security/research/tra-2024-40"],"products":["flowiseai:embed","flowiseai:flowise"],"source":"nvd","synced_at":"2026-10-19T21:54:38.012257375+00:00"},"epss":{"cve":"CVE-2024-9148","score":0.00559,"percentile":0.46589,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-m5p9-xvxj-64c8","url":"https://osv.dev/vulnerability/GHSA-m5p9-xvxj-64c8","summary":"Flowise and Flowise Chat Embed vulnerable to Stored Cross-site Scripting","modified":"2024-09-30T21:27:16.250091Z","packages":[{"ecosystem":"npm","name":"flowise-embed","purl":"pkg:npm/flowise-embed","ranges":["<2.0.0"],"fixed":["2.0.0"]},{"ecosystem":"npm","name":"flowise","purl":"pkg:npm/flowise","ranges":["<2.1.1"],"fixed":["2.1.1"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}