{"cve":"CVE-2024-57556","nvd":{"published":"2025-01-23T22:15:15.277","modified":"2026-06-17T08:13:42.423","status":"Analyzed","description":"Cross Site Scripting vulnerability in nbubna store v.2.14.2 and before allows a remote attacker to execute arbitrary code via the store.deep.js component","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","score":6.1},"cwes":["CWE-79"],"references":["https://github.com/nbubna/store/issues/127"],"products":["nbubna:store"],"source":"nvd","synced_at":"2026-10-19T21:58:41.599736885+00:00"},"epss":{"cve":"CVE-2024-57556","score":0.00363,"percentile":0.30107,"date":"2026-11-01"},"kev":null,"osv":[{"id":"GHSA-w5hq-hm5m-4548","url":"https://osv.dev/vulnerability/GHSA-w5hq-hm5m-4548","summary":"Cross Site Scripting vulnerability in store2","modified":"2025-01-24T22:57:03.673863Z","packages":[{"ecosystem":"npm","name":"store2","purl":"pkg:npm/store2","ranges":["<2.14.4"],"fixed":["2.14.4"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}