{"cve":"CVE-2024-56332","nvd":{"published":"2025-01-03T21:15:13.550","modified":"2026-06-17T08:12:03.743","status":"Analyzed","description":"Next.js is a React framework for building full-stack web applications. Starting in version 13.0.0 and prior to versions 13.5.8, 14.2.21, and 15.1.2, Next.js is vulnerable to a Denial of Service (DoS) attack that allows attackers to construct requests that leaves requests to Server Actions hanging until the hosting provider cancels the function execution. This vulnerability can also be used as a Denial of Wallet (DoW) attack when deployed in providers billing by response times. (Note: Next.js server is idle during that time and only keeps the connection open. CPU and memory footprint are low during that time.). Deployments without any protection against long running Server Action invocations are especially vulnerable. Hosting providers like Vercel or Netlify set a default maximum duration on function execution to reduce the risk of excessive billing. This is the same issue as if the incoming HTTP request has an invalid `Content-Length` header or never closes. If the host has no other mitigations to those then this vulnerability is novel. This vulnerability affects only Next.js deployments using Server Actions. The issue was resolved in Next.js 13.5.8, 14.2.21, and 15.1.2. We recommend that users upgrade to a safe version. There are no official workarounds.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L","score":5.3},"cwes":["CWE-770"],"references":["https://github.com/vercel/next.js/security/advisories/GHSA-7m27-7ghc-44w9"],"products":["vercel:next.js"],"source":"nvd","synced_at":"2026-10-19T21:57:56.913276502+00:00"},"epss":{"cve":"CVE-2024-56332","score":0.00802,"percentile":0.56666,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-7m27-7ghc-44w9","url":"https://osv.dev/vulnerability/GHSA-7m27-7ghc-44w9","summary":"Next.js Allows a Denial of Service (DoS) with Server Actions","modified":"2026-09-10T03:50:21.823305821Z","packages":[{"ecosystem":"npm","name":"next","purl":"pkg:npm/next","ranges":[">=13.0.0 <13.5.8"],"fixed":["13.5.8"]},{"ecosystem":"npm","name":"next","purl":"pkg:npm/next","ranges":[">=14.0.0 <14.2.21"],"fixed":["14.2.21"]},{"ecosystem":"npm","name":"next","purl":"pkg:npm/next","ranges":[">=15.0.0 <15.1.2"],"fixed":["15.1.2"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}