{"cve":"CVE-2024-54003","nvd":{"published":"2024-11-27T17:15:15.333","modified":"2026-06-17T08:09:38.707","status":"Analyzed","description":"Jenkins Simple Queue Plugin 1.4.4 and earlier does not escape the view name, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with View/Create permission.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H","score":8.0},"cwes":["CWE-79"],"references":["https://www.jenkins.io/security/advisory/2024-11-27/#SECURITY-3467"],"products":["jenkins:simple_queue"],"source":"nvd","synced_at":"2026-10-19T21:57:34.731061660+00:00"},"epss":{"cve":"CVE-2024-54003","score":0.801,"percentile":0.99616,"date":"2026-11-01"},"kev":null,"osv":[{"id":"GHSA-4gwv-fpmg-cmv2","url":"https://osv.dev/vulnerability/GHSA-4gwv-fpmg-cmv2","summary":"Jenkins Simple Queue Plugin has stored cross-site scripting (XSS) vulnerability","modified":"2024-11-27T20:12:15.489750Z","packages":[{"ecosystem":"Maven","name":"io.jenkins.plugins:simple-queue","purl":"pkg:maven/io.jenkins.plugins/simple-queue","ranges":["<1.4.5"],"fixed":["1.4.5"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}