{"cve":"CVE-2024-53949","nvd":{"published":"2024-12-09T14:15:12.647","modified":"2026-06-17T08:09:33.453","status":"Modified","description":"Improper Authorization vulnerability in Apache Superset when FAB_ADD_SECURITY_API is enabled (disabled by default). Allows for lower privilege users to use this API.\n\n issue affects Apache Superset: from 2.0.0 before 4.1.0.\n\nUsers are recommended to upgrade to version 4.1.0, which fixes the issue.","cvss_v4":{"vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N","score":7.6},"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N","score":6.5},"cwes":["CWE-863"],"references":["https://lists.apache.org/thread/d3scbwmfpzbpm6npnzdw5y4owtqqyq8d","http://www.openwall.com/lists/oss-security/2024/12/09/4"],"products":["apache:superset"],"source":"nvd","synced_at":"2026-10-19T21:57:36.180738747+00:00"},"epss":{"cve":"CVE-2024-53949","score":0.00716,"percentile":0.53791,"date":"2026-11-01"},"kev":null,"osv":[{"id":"GHSA-35fc-9hrj-3585","url":"https://osv.dev/vulnerability/GHSA-35fc-9hrj-3585","summary":"Apache Superset: Lower privilege users are able to create Role when FAB_ADD_SECURITY_API is enabled","modified":"2026-07-07T17:56:20.799591812Z","packages":[{"ecosystem":"PyPI","name":"apache-superset","purl":"pkg:pypi/apache-superset","ranges":[">=2.0.0 <4.1.0"],"fixed":["4.1.0"]}]},{"id":"PYSEC-2026-1156","url":"https://osv.dev/vulnerability/PYSEC-2026-1156","summary":"Apache Superset: Lower privilege users are able to create Role when FAB_ADD_SECURITY_API is enabled","modified":"2026-07-07T17:56:20.799591812Z","packages":[{"ecosystem":"PyPI","name":"apache-superset","purl":"pkg:pypi/apache-superset","ranges":[">=2.0.0 <4.1.0"],"fixed":["4.1.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}