{"cve":"CVE-2024-5130","nvd":{"published":"2024-06-06T19:16:04.813","modified":"2026-06-17T08:15:15.717","status":"Modified","description":"An Incorrect Authorization vulnerability exists in lunary-ai/lunary versions up to and including 1.2.2, which allows unauthenticated users to delete any dataset. The vulnerability is due to the lack of proper authorization checks in the dataset deletion endpoint. Specifically, the endpoint does not verify if the provided project ID belongs to the current user, thereby allowing any dataset to be deleted without proper authentication. This issue was fixed in version 1.2.8.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","score":7.5},"cwes":["CWE-862","CWE-639"],"references":["https://github.com/lunary-ai/lunary/commit/14078c1d2b8766075bf655f187ece24c7a787776","https://huntr.com/bounties/e81a9871-308d-4628-9726-af66643a16fe","https://github.com/lunary-ai/lunary/commit/14078c1d2b8766075bf655f187ece24c7a787776","https://huntr.com/bounties/e81a9871-308d-4628-9726-af66643a16fe"],"products":["lunary:lunary"],"source":"nvd","synced_at":"2026-10-19T21:51:20.603330631+00:00"},"epss":{"cve":"CVE-2024-5130","score":0.00484,"percentile":0.41719,"date":"2026-10-31"},"kev":null,"osv":[],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}