{"cve":"CVE-2024-48964","nvd":{"published":"2024-10-23T19:15:19.833","modified":"2026-06-17T07:59:08.103","status":"Analyzed","description":"The package Snyk CLI before 1.1294.0 is vulnerable to Code Injection when scanning an untrusted Gradle project. The vulnerability can be triggered if Snyk test is run inside the untrusted project due to the improper handling of the current working directory name. Snyk recommends only scanning trusted projects.","cvss_v4":{"vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","score":7.5},"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","score":8.8},"cwes":["CWE-94","CWE-78"],"references":["https://github.com/snyk/snyk-gradle-plugin/commit/2f5ee7579f00660282dd161a0b79690f4a9c865d"],"products":["snyk:snyk_cli"],"source":"nvd","synced_at":"2026-10-19T21:56:33.105311382+00:00"},"epss":{"cve":"CVE-2024-48964","score":0.00469,"percentile":0.40573,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-qqqw-gm93-qf6m","url":"https://osv.dev/vulnerability/GHSA-qqqw-gm93-qf6m","summary":"OS Command Injection in Snyk gradle plugin","modified":"2026-09-10T03:50:20.137692918Z","packages":[{"ecosystem":"npm","name":"snyk-gradle-plugin","purl":"pkg:npm/snyk-gradle-plugin","ranges":["<4.5.0"],"fixed":["4.5.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}