{"cve":"CVE-2024-47614","nvd":{"published":"2024-10-03T15:15:14.720","modified":"2026-06-17T07:57:24.160","status":"Deferred","description":"async-graphql is a GraphQL server library implemented in Rust. async-graphql before 7.0.10 does not limit the number of directives for a field. This can lead to Service Disruption, Resource Exhaustion, and User Experience Degradation. This vulnerability is fixed in 7.0.10.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","score":7.5},"cwes":["CWE-770"],"references":["https://github.com/async-graphql/async-graphql/commit/7f1791488463d4e9c5adcd543962173e2f6cbd34","https://github.com/async-graphql/async-graphql/security/advisories/GHSA-5gc2-7c65-8fq8"],"products":[],"source":"nvd","synced_at":"2026-10-19T21:55:31.737901711+00:00"},"epss":{"cve":"CVE-2024-47614","score":0.00576,"percentile":0.47538,"date":"2026-11-01"},"kev":null,"osv":[{"id":"GHSA-5gc2-7c65-8fq8","url":"https://osv.dev/vulnerability/GHSA-5gc2-7c65-8fq8","summary":"async-graphql Directive Overload","modified":"2024-10-03T18:57:19.692628Z","packages":[{"ecosystem":"crates.io","name":"async-graphql","purl":"pkg:cargo/async-graphql","ranges":["<7.0.10"],"fixed":["7.0.10"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}