{"cve":"CVE-2024-47075","nvd":{"published":"2024-09-26T18:15:08.757","modified":"2026-06-17T07:56:30.017","status":"Analyzed","description":"LayUI is a native minimalist modular Web UI component library. Versions prior to 2.9.17 have a DOM Clobbering vulnerability that can lead to Cross-site Scripting (XSS) on web pages where attacker-controlled HTML elements (e.g., `img` tags with unsanitized `name` attributes) are present. Version 2.9.17 fixes this issue.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","score":6.1},"cwes":["CWE-79"],"references":["https://github.com/layui/layui/commit/f756b41d63bf3d488a2cb042918638c9851bf2b0","https://github.com/layui/layui/security/advisories/GHSA-j827-6rgf-9629"],"products":["layui:layui"],"source":"nvd","synced_at":"2026-10-19T21:54:38.012257375+00:00"},"epss":{"cve":"CVE-2024-47075","score":0.00339,"percentile":0.2735,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-j827-6rgf-9629","url":"https://osv.dev/vulnerability/GHSA-j827-6rgf-9629","summary":"Layui has DOM Clobbering gadgets that leads to Cross-site Scripting","modified":"2025-08-15T16:25:42Z","packages":[{"ecosystem":"npm","name":"layui","purl":"pkg:npm/layui","ranges":["<2.9.17"],"fixed":["2.9.17"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}