{"cve":"CVE-2024-45399","nvd":{"published":"2024-09-04T20:15:09.257","modified":"2026-06-17T07:54:08.377","status":"Analyzed","description":"Indico is an event management system that uses Flask-Multipass, a multi-backend authentication system for Flask. In Indico prior to version 3.3.4, corresponding to Flask-Multipass prior to version 0.5.5, there is a Cross-Site-Scripting vulnerability during account creation when redirecting to the `next` URL. Exploitation requires initiating the account creation process with a maliciously crafted link, and then finalizing the signup process. Because of this, it can only target newly created (and thus unprivileged) Indico users. Indico 3.3.4 upgrades the dependency on Flask-Multipass to version 0.5.5, which fixes the issue. Those who build the Indico package themselves and cannot upgrade can update the `flask-multipass` dependency to `>=0.5.5` which fixes the vulnerability. Otherwise one could configure one's web server to disallow requests containing a query string with a `next` parameter that starts with `javascript:`.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","score":6.1},"cwes":["CWE-79"],"references":["https://github.com/indico/flask-multipass/commit/0bdcf656d469e5f675cb56fd644d82fea3a97c2a","https://github.com/indico/indico/commit/7dcb573837b9fd09d95f74d1baeae225b164cc8f","https://github.com/indico/indico/releases/tag/v3.3.4","https://github.com/indico/indico/security/advisories/GHSA-rrqf-w74j-24ff"],"products":["cern:indico"],"source":"nvd","synced_at":"2026-10-19T21:54:16.205165117+00:00"},"epss":{"cve":"CVE-2024-45399","score":0.00383,"percentile":0.32376,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-rrqf-w74j-24ff","url":"https://osv.dev/vulnerability/GHSA-rrqf-w74j-24ff","summary":"Indico has a Cross-Site-Scripting during account creation","modified":"2024-09-25T18:03:00.150978Z","packages":[{"ecosystem":"PyPI","name":"indico","purl":"pkg:pypi/indico","ranges":["<3.3.4"],"fixed":["3.3.4"]}]},{"id":"PYSEC-2024-90","url":"https://osv.dev/vulnerability/PYSEC-2024-90","summary":"","modified":"2024-09-25T06:57:02.422758Z","packages":[{"ecosystem":"PyPI","name":"indico","purl":"pkg:pypi/indico","ranges":["<3.3.4"],"fixed":["3.3.4"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}