{"cve":"CVE-2024-45042","nvd":{"published":"2024-09-26T18:15:07.463","modified":"2026-06-17T07:53:28.863","status":"Deferred","description":"Ory Kratos is an identity, user management and authentication system for cloud services. Prior to version 1.3.0, given a number of preconditions, the `highest_available` setting will incorrectly assume that the identity’s highest available AAL is `aal1` even though it really is `aal2`. This means that the `highest_available` configuration will act as if the user has only one factor set up, for that particular user. This means that they can call the settings and whoami endpoint without a `aal2` session, even though that should be disallowed. An attacker would need to steal or guess a valid login OTP of a user who has only OTP for login enabled and who has an incorrect `available_aal` value stored, to exploit this vulnerability. All other aspects of the session (e.g. the session’s aal) are not impacted by this issue. On the Ory Network, only 0.00066% of registered users were affected by this issue, and most of those users appeared to be test users. Their respective AAL values have since been updated and they are no longer vulnerable to this attack. Version 1.3.0 is not affected by this issue. As a workaround, those who require MFA should disable the passwordless code login method. If that is not possible, check the sessions `aal` to identify if the user has `aal1` or `aal2`.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:N/A:N","score":4.4},"cwes":["CWE-287"],"references":["https://github.com/ory/kratos/security/advisories/GHSA-wc43-73w7-x2f5"],"products":[],"source":"nvd","synced_at":"2026-10-19T21:54:38.012257375+00:00"},"epss":{"cve":"CVE-2024-45042","score":0.00327,"percentile":0.25831,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-wc43-73w7-x2f5","url":"https://osv.dev/vulnerability/GHSA-wc43-73w7-x2f5","summary":"Ory Kratos's setting required_aal `highest_available` does not properly respect code + mfa credentials","modified":"2024-09-26T21:11:01Z","packages":[{"ecosystem":"Go","name":"github.com/ory/kratos","purl":"pkg:golang/github.com/ory/kratos","ranges":["<1.3.0"],"fixed":["1.3.0"]}]},{"id":"GO-2024-3160","url":"https://osv.dev/vulnerability/GO-2024-3160","summary":"Ory Kratos's setting required_aal `highest_available` does not properly respect code + mfa credentials in github.com/ory/kratos","modified":"2026-03-03T04:52:02.769502Z","packages":[{"ecosystem":"Go","name":"github.com/ory/kratos","purl":"pkg:golang/github.com/ory/kratos","ranges":["<1.3.0"],"fixed":["1.3.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}