{"cve":"CVE-2024-43115","nvd":{"published":"2025-09-03T09:15:34.047","modified":"2026-06-17T07:50:27.953","status":"Modified","description":"Improper Input Validation vulnerability in Apache DolphinScheduler. An authenticated user can execute any shell script server by alert script.\n\n\nThis issue affects Apache DolphinScheduler: before 3.2.2.\n\nUsers are recommended to upgrade to version 3.3.1, which fixes the issue.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","score":8.8},"cwes":["CWE-20"],"references":["https://lists.apache.org/thread/qm36nrsv1vrr2j4o5q2wo75h3686hrnj","http://www.openwall.com/lists/oss-security/2025/09/03/1"],"products":["apache:dolphinscheduler"],"source":"nvd","synced_at":"2026-10-19T22:07:46.309729541+00:00"},"epss":{"cve":"CVE-2024-43115","score":0.00592,"percentile":0.48294,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-3vcp-r62v-xpvg","url":"https://osv.dev/vulnerability/GHSA-3vcp-r62v-xpvg","summary":"Apache DolphinScheduler vulnerable to Alert Script Attack","modified":"2025-11-05T20:52:35.994645Z","packages":[{"ecosystem":"Maven","name":"org.apache.dolphinscheduler:dolphinscheduler","purl":"pkg:maven/org.apache.dolphinscheduler/dolphinscheduler","ranges":["<3.2.2"],"fixed":["3.2.2"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}