{"cve":"CVE-2024-42447","nvd":{"published":"2024-08-05T08:15:56.397","modified":"2026-06-17T07:49:28.000","status":"Modified","description":"Insufficient Session Expiration vulnerability in Apache Airflow Providers FAB.\n\nThis issue affects Apache Airflow Providers FAB: 1.2.1 (when used with Apache Airflow 2.9.3) and FAB 1.2.0 for all Airflow versions. The FAB provider prevented the user from logging out.  \n\n* FAB provider 1.2.1 only affected Airflow 2.9.3 (earlier and later versions of Airflow are not affected)\n\n* FAB provider 1.2.0 affected all versions of Airflow.\n\nUsers who run Apache Airflow 2.9.3 are recommended to upgrade to Apache Airflow Providers FAB version 1.2.2 which fixes the issue.\n\nUsers who run Any Apache Airflow version and have FAB provider 1.2.0 are recommended to upgrade to Apache Airflow Providers FAB version 1.2.2 which fixes the issue.\n\nAlso upgrading Apache Airflow to latest version available is recommended.\n\nNote: Early version of Airflow reference container images of Airflow 2.9.3 and constraint files contained FAB provider 1.2.1 version, but this is fixed in updated versions of the images. \n\nUsers are advised to pull the latest Airflow images or reinstall FAB provider according to the current constraints.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","score":9.8},"cwes":["CWE-613"],"references":["https://github.com/apache/airflow/pull/40784","https://lists.apache.org/thread/2zoo8cjlwfjhbfdxfgltcm0hnc0qmc52","http://www.openwall.com/lists/oss-security/2024/08/04/2"],"products":["apache:apache-airflow-providers-fab"],"source":"nvd","synced_at":"2026-10-19T21:53:51.317825789+00:00"},"epss":{"cve":"CVE-2024-42447","score":0.00929,"percentile":0.60582,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-62qf-qm3g-fvcw","url":"https://osv.dev/vulnerability/GHSA-62qf-qm3g-fvcw","summary":"Apache Airflow Providers FAB Insufficient Session Expiration vulnerability","modified":"2026-09-10T03:50:18.084755511Z","packages":[{"ecosystem":"PyPI","name":"apache-airflow-providers-fab","purl":"pkg:pypi/apache-airflow-providers-fab","ranges":[">=1.2.0 <1.2.2"],"fixed":["1.2.2"]}]},{"id":"PYSEC-2024-265","url":"https://osv.dev/vulnerability/PYSEC-2024-265","summary":"","modified":"2026-07-07T17:57:04.555210725Z","packages":[{"ecosystem":"PyPI","name":"apache-airflow","purl":"pkg:pypi/apache-airflow","ranges":["<=1.2.1","<=1.2.0"],"fixed":[]}]},{"id":"PYSEC-2026-1146","url":"https://osv.dev/vulnerability/PYSEC-2026-1146","summary":"Apache Airflow Providers FAB Insufficient Session Expiration vulnerability","modified":"2026-07-07T17:57:04.555210725Z","packages":[{"ecosystem":"PyPI","name":"apache-airflow-providers-fab","purl":"pkg:pypi/apache-airflow-providers-fab","ranges":[">=1.2.0 <1.2.2"],"fixed":["1.2.2"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}