{"cve":"CVE-2024-42360","nvd":{"published":"2024-08-14T20:15:12.533","modified":"2026-10-29T14:17:40.420","status":"Analyzed","description":"SequenceServer lets you rapidly set up a BLAST+ server with an intuitive user interface for personal or group use. Several HTTP endpoints did not properly sanitize user input and/or query parameters. This could be exploited to inject and run unwanted shell commands. This vulnerability has been fixed in 3.1.2.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","score":9.8},"cwes":["CWE-77"],"references":["https://github.com/wurmlab/sequenceserver/commit/457e52709f7f9ed2fceed59b3db564cb50785dba","https://github.com/wurmlab/sequenceserver/security/advisories/GHSA-qv32-5wm2-p32h"],"products":["wurmlab:sequenceserver"],"source":"nvd","synced_at":"2026-10-29T14:40:56.811978014+00:00"},"epss":{"cve":"CVE-2024-42360","score":0.00584,"percentile":0.47765,"date":"2026-10-28"},"kev":null,"osv":[{"id":"GHSA-qv32-5wm2-p32h","url":"https://osv.dev/vulnerability/GHSA-qv32-5wm2-p32h","summary":"Command Injection in sequenceserver","modified":"2024-08-14T22:21:07.046729Z","packages":[{"ecosystem":"RubyGems","name":"sequenceserver","purl":"pkg:gem/sequenceserver","ranges":["<3.1.2"],"fixed":["3.1.2"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}