{"cve":"CVE-2024-41942","nvd":{"published":"2024-08-08T15:15:17.527","modified":"2026-06-17T07:48:29.953","status":"Analyzed","description":"JupyterHub is software that allows one to create a multi-user server for Jupyter notebooks. Prior to versions 4.1.6 and 5.1.0, if a user is granted the `admin:users` scope, they may escalate their own privileges by making themselves a full admin user. The impact is relatively small in that `admin:users` is already an extremely privileged scope only granted to trusted users.\nIn effect, `admin:users` is equivalent to `admin=True`, which is not intended. Note that the change here only prevents escalation to the built-in JupyterHub admin role that has unrestricted permissions. It does not prevent users with e.g. `groups` permissions from granting themselves or other users permissions via group membership, which is intentional. Versions 4.1.6 and 5.1.0 fix this issue.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H","score":7.2},"cwes":["CWE-274"],"references":["https://github.com/jupyterhub/jupyterhub/commit/99e2720b0fc626cbeeca3c6337f917fdacfaa428","https://github.com/jupyterhub/jupyterhub/commit/ff2db557a85b6980f90c3158634bf924063ab8ba","https://github.com/jupyterhub/jupyterhub/security/advisories/GHSA-9x4q-3gxw-849f"],"products":["jupyter:jupyterhub"],"source":"nvd","synced_at":"2026-10-19T21:53:51.317825789+00:00"},"epss":{"cve":"CVE-2024-41942","score":0.0059,"percentile":0.4822,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-9x4q-3gxw-849f","url":"https://osv.dev/vulnerability/GHSA-9x4q-3gxw-849f","summary":"JupyterHub has a privilege escalation vulnerability with the `admin:users` scope","modified":"2026-09-10T03:50:17.487409719Z","packages":[{"ecosystem":"PyPI","name":"jupyterhub","purl":"pkg:pypi/jupyterhub","ranges":["<4.1.6"],"fixed":["4.1.6"]},{"ecosystem":"PyPI","name":"jupyterhub","purl":"pkg:pypi/jupyterhub","ranges":[">=5.0.0 <5.1.0"],"fixed":["5.1.0"]}]},{"id":"PYSEC-2024-200","url":"https://osv.dev/vulnerability/PYSEC-2024-200","summary":"","modified":"2025-01-19T16:57:10.916115Z","packages":[{"ecosystem":"PyPI","name":"jupyterhub","purl":"pkg:pypi/jupyterhub","ranges":["<4.1.6"],"fixed":["4.1.6"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}