{"cve":"CVE-2024-41815","nvd":{"published":"2024-07-26T21:15:14.370","modified":"2026-06-17T07:48:17.040","status":"Modified","description":"Starship is a cross-shell prompt. Starting in version 1.0.0 and prior to version 1.20.0, undocumented and unpredictable shell expansion and/or quoting rules make it easily to accidentally cause shell injection when using custom commands with starship in bash. This issue only affects users with custom commands, so the scope is limited, and without knowledge of others' commands, it could be hard to successfully target someone. Version 1.20.0 fixes the vulnerability.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H","score":7.0},"cwes":["CWE-78","CWE-77"],"references":["https://github.com/starship/starship/commit/cfc58161e0ec595db90af686ad77a73df6d44d74","https://github.com/starship/starship/releases/tag/v1.20.0","https://github.com/starship/starship/security/advisories/GHSA-vx24-x4mv-vwr5","https://github.com/starship/starship/commit/cfc58161e0ec595db90af686ad77a73df6d44d74","https://github.com/starship/starship/releases/tag/v1.20.0"],"products":["starship:starship"],"source":"nvd","synced_at":"2026-10-19T21:53:51.317825789+00:00"},"epss":{"cve":"CVE-2024-41815","score":0.00463,"percentile":0.40165,"date":"2026-11-01"},"kev":null,"osv":[{"id":"GHSA-vx24-x4mv-vwr5","url":"https://osv.dev/vulnerability/GHSA-vx24-x4mv-vwr5","summary":"Starship vulnerable to shell injection via undocumented, unpredictable shell expansion in custom commands","modified":"2025-12-22T16:44:26.461289Z","packages":[{"ecosystem":"crates.io","name":"starship","purl":"pkg:cargo/starship","ranges":[">=1.0.0 <1.20.0"],"fixed":["1.20.0"]}]},{"id":"RUSTSEC-2024-0446","url":"https://osv.dev/vulnerability/RUSTSEC-2024-0446","summary":"Shell expansion in custom commands","modified":"2026-10-12T18:00:11.506829501Z","packages":[{"ecosystem":"crates.io","name":"starship","purl":"pkg:cargo/starship","ranges":[">=1.0.1-0 <1.20.0"],"fixed":["1.20.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}