{"cve":"CVE-2024-41656","nvd":{"published":"2024-07-23T22:15:08.970","modified":"2026-06-17T07:47:59.707","status":"Analyzed","description":"Sentry is an error tracking and performance monitoring platform. Starting in version 10.0.0 and prior to version 24.7.1, an unsanitized payload sent by an Integration platform integration allows storing arbitrary HTML tags on the Sentry side with the subsequent rendering them on the Issues page. Self-hosted Sentry users may be impacted in case of untrustworthy Integration platform integrations sending external issues from their side to Sentry. A patch has been released in Sentry 24.7.1. For Sentry SaaS customers, no action is needed. This has been patched on July 23, and even prior to the fix, the exploitation was not possible due to the strict Content Security Policy deployed on sentry.io site. For self-hosted users, the maintainers of Sentry strongly recommend upgrading Sentry to the latest version. If it is not possible, one could enable CSP on one's self-hosted installation with `CSP_REPORT_ONLY = False` (enforcing mode). This will mitigate the risk of cross-site scripting.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","score":5.4},"cwes":["CWE-79"],"references":["https://github.com/getsentry/self-hosted/releases/tag/24.7.1","https://github.com/getsentry/sentry/commit/5c679521f1539eabfb81287bfc30f34dbecd373e","https://github.com/getsentry/sentry/pull/74648","https://github.com/getsentry/sentry/security/advisories/GHSA-fm88-hc3v-3www","https://github.com/getsentry/self-hosted/releases/tag/24.7.1"],"products":["sentry:sentry"],"source":"nvd","synced_at":"2026-10-19T21:52:42.518321223+00:00"},"epss":{"cve":"CVE-2024-41656","score":0.00467,"percentile":0.40487,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-fm88-hc3v-3www","url":"https://osv.dev/vulnerability/GHSA-fm88-hc3v-3www","summary":"Sentry vulnerable to stored Cross-Site Scripting (XSS)","modified":"2026-09-10T03:50:16.452916623Z","packages":[{"ecosystem":"PyPI","name":"sentry","purl":"pkg:pypi/sentry","ranges":[">=10.0.0 <24.7.1"],"fixed":["24.7.1"]}]},{"id":"PYSEC-2026-1914","url":"https://osv.dev/vulnerability/PYSEC-2026-1914","summary":"Sentry vulnerable to stored Cross-Site Scripting (XSS)","modified":"2026-07-07T17:48:09.616255779Z","packages":[{"ecosystem":"PyPI","name":"sentry","purl":"pkg:pypi/sentry","ranges":[">=10.0.0 <24.7.1"],"fixed":["24.7.1"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}