{"cve":"CVE-2024-41177","nvd":{"published":"2025-08-03T10:15:27.240","modified":"2026-06-17T07:47:25.343","status":"Modified","description":"Incomplete Blacklist to Cross-Site Scripting vulnerability in Apache Zeppelin.\n\nThis issue affects Apache Zeppelin: before 0.12.0.\n\nUsers are recommended to upgrade to version 0.12.0, which fixes the issue.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","score":6.1},"cwes":["CWE-79"],"references":["https://github.com/apache/zeppelin/pull/4755","https://github.com/apache/zeppelin/pull/4795","https://lists.apache.org/thread/nwh8vh9f3pnvt04n8z4g2kbddh62blr6","http://www.openwall.com/lists/oss-security/2025/08/03/4"],"products":["apache:zeppelin"],"source":"nvd","synced_at":"2026-10-19T22:06:45.861874017+00:00"},"epss":{"cve":"CVE-2024-41177","score":0.00679,"percentile":0.52376,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-p288-459w-jxj6","url":"https://osv.dev/vulnerability/GHSA-p288-459w-jxj6","summary":"Apache Zeppelin: XSS in the Helium module","modified":"2025-11-05T20:53:00.666298Z","packages":[{"ecosystem":"Maven","name":"org.apache.zeppelin:zeppelin-web","purl":"pkg:maven/org.apache.zeppelin/zeppelin-web","ranges":["<0.12.0"],"fixed":["0.12.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}