{"cve":"CVE-2024-37300","nvd":{"published":"2024-06-12T16:15:12.097","modified":"2026-06-17T07:38:05.953","status":"Deferred","description":"OAuthenticator is software that allows OAuth2 identity providers to be plugged in and used with JupyterHub. JupyterHub < 5.0, when used with `GlobusOAuthenticator`, could be configured to allow all users from a particular institution only. This worked fine prior to JupyterHub 5.0, because `allow_all` did not take precedence over `identity_provider`. Since JupyterHub 5.0, `allow_all` does take precedence over `identity_provider`. On a hub with the same config, now all users will be allowed to login, regardless of `identity_provider`. `identity_provider` will basically be ignored. This is a documented change in JupyterHub 5.0, but is likely to catch many users by surprise. OAuthenticator 16.3.1 fixes the issue with JupyterHub 5.0, and does not affect previous versions. As a workaround, do not upgrade to JupyterHub 5.0 when using `GlobusOAuthenticator` in the prior configuration.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N","score":8.1},"cwes":["CWE-863"],"references":["https://github.com/jupyterhub/oauthenticator/commit/d1aea05fa89f2beae15ab0fa0b0d071030f79654","https://github.com/jupyterhub/oauthenticator/security/advisories/GHSA-gprj-3p75-f996","https://jupyterhub.readthedocs.io/en/stable/howto/upgrading-v5.html#authenticator-allow-all-and-allow-existing-users","https://github.com/jupyterhub/oauthenticator/commit/d1aea05fa89f2beae15ab0fa0b0d071030f79654","https://github.com/jupyterhub/oauthenticator/security/advisories/GHSA-gprj-3p75-f996"],"products":[],"source":"nvd","synced_at":"2026-10-19T21:51:20.603330631+00:00"},"epss":{"cve":"CVE-2024-37300","score":0.00405,"percentile":0.34771,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-gprj-3p75-f996","url":"https://osv.dev/vulnerability/GHSA-gprj-3p75-f996","summary":"Globus `identity_provider` restriction ignored when used with `allow_all` in JupyterHub 5.0","modified":"2026-09-10T03:50:15.608095310Z","packages":[{"ecosystem":"PyPI","name":"oauthenticator","purl":"pkg:pypi/oauthenticator","ranges":["<16.3.1"],"fixed":["16.3.1"]}]},{"id":"PYSEC-2026-1711","url":"https://osv.dev/vulnerability/PYSEC-2026-1711","summary":"Globus `identity_provider` restriction ignored when used with `allow_all` in JupyterHub 5.0","modified":"2026-07-07T17:46:29.847756741Z","packages":[{"ecosystem":"PyPI","name":"oauthenticator","purl":"pkg:pypi/oauthenticator","ranges":["<16.3.1"],"fixed":["16.3.1"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}