{"cve":"CVE-2024-34693","nvd":{"published":"2024-06-20T09:15:11.683","modified":"2026-06-17T07:33:53.447","status":"Modified","description":"Improper Input Validation vulnerability in Apache Superset, allows for an authenticated attacker to create a MariaDB connection with local_infile enabled. If both the MariaDB server (off by default) and the local mysql client on the web server are set to allow for local infile, it's possible for the attacker to execute a specific MySQL/MariaDB SQL command that is able to read files from the server and insert their content on a MariaDB database table.This issue affects Apache Superset: before 3.1.3 and version 4.0.0\n\nUsers are recommended to upgrade to version 4.0.1 or 3.1.3, which fixes the issue.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N","score":5.3},"cwes":["CWE-20"],"references":["http://www.openwall.com/lists/oss-security/2024/06/20/1","https://lists.apache.org/thread/1803x1s34m7r71h1k0q1njol8k6fmyon","http://www.openwall.com/lists/oss-security/2024/06/20/1","https://lists.apache.org/thread/1803x1s34m7r71h1k0q1njol8k6fmyon"],"products":["apache:superset"],"source":"nvd","synced_at":"2026-10-19T21:52:00.836172422+00:00"},"epss":{"cve":"CVE-2024-34693","score":0.01584,"percentile":0.75568,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-hcr7-cqwc-q5gq","url":"https://osv.dev/vulnerability/GHSA-hcr7-cqwc-q5gq","summary":"Apache Superset server arbitrary file read ","modified":"2026-07-07T17:57:00.178717904Z","packages":[{"ecosystem":"PyPI","name":"apache-superset","purl":"pkg:pypi/apache-superset","ranges":["<3.1.3"],"fixed":["3.1.3"]},{"ecosystem":"PyPI","name":"apache-superset","purl":"pkg:pypi/apache-superset","ranges":[">=4.0.0 <4.0.1"],"fixed":["4.0.1"]}]},{"id":"PYSEC-2026-1183","url":"https://osv.dev/vulnerability/PYSEC-2026-1183","summary":"Apache Superset server arbitrary file read ","modified":"2026-07-07T17:57:00.178717904Z","packages":[{"ecosystem":"PyPI","name":"apache-superset","purl":"pkg:pypi/apache-superset","ranges":["<3.1.3",">=4.0.0 <4.0.1"],"fixed":["3.1.3","4.0.1"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}