{"cve":"CVE-2024-32970","nvd":{"published":"2024-04-30T23:15:06.483","modified":"2026-06-17T07:30:47.617","status":"Deferred","description":"Phlex is a framework for building object-oriented views in Ruby. In affected versions there is a potential cross-site scripting (XSS) vulnerability that can be exploited via maliciously crafted user data. Since the last two vulnerabilities https://github.com/phlex-ruby/phlex/security/advisories/GHSA-242p-4v39-2v8g and https://github.com/phlex-ruby/phlex/security/advisories/GHSA-g7xq-xv8c-h98c, we have invested in extensive browser tests. It was these new tests that helped us uncover these issues. As of now the project exercises every possible attack vector the developers can think of — including enumerating every ASCII character, and we run these tests in Chrome, Firefox and Safari. Additionally, we test against a list of 6613 known XSS payloads (see: payloadbox/xss-payload-list). The reason these issues were not detected before is the escapes were working as designed. However, their design didn't take into account just how recklessly permissive browsers are when it comes to executing unsafe JavaScript via HTML attributes. If you render an `<a>` tag with an `href` attribute set to a user-provided link, that link could potentially execute JavaScript when clicked by another user. If you splat user-provided attributes when rendering any HTML or SVG tag, malicious event attributes could be included in the output, executing JavaScript when the events are triggered by another user. Patches are available on RubyGems for all minor versions released in the last year. Users are advised to upgrade. Users unable to upgrade should configure a Content Security Policy that does not allow `unsafe-inline` which would effectively prevent this vulnerability from being exploited. Users who upgrade are also advised to configure a Content Security Policy header that does not allow `unsafe-inline`.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:N","score":7.1},"cwes":["CWE-79"],"references":["https://developer.mozilla.org/en-US/docs/Web/HTTP/Headers/Content-Security-Policy","https://developer.mozilla.org/en-US/docs/Web/HTTP/Headers/Content-Security-Policy#unsafe-inline","https://github.com/payloadbox/xss-payload-list","https://github.com/phlex-ruby/phlex/commit/da8f94342a84cff9d78c98bcc3b3604ee2e577d2","https://github.com/phlex-ruby/phlex/security/advisories/GHSA-9p57-h987-4vgx"],"products":[],"source":"nvd","synced_at":"2026-10-19T21:49:08.435428910+00:00"},"epss":{"cve":"CVE-2024-32970","score":0.00713,"percentile":0.53677,"date":"2026-11-01"},"kev":null,"osv":[{"id":"GHSA-9p57-h987-4vgx","url":"https://osv.dev/vulnerability/GHSA-9p57-h987-4vgx","summary":"Phlex vulnerable to Cross-site Scripting (XSS) via maliciously formed HTML attribute names and values","modified":"2026-09-10T03:50:13.687671369Z","packages":[{"ecosystem":"RubyGems","name":"phlex","purl":"pkg:gem/phlex","ranges":["<1.9.3"],"fixed":["1.9.3"]},{"ecosystem":"RubyGems","name":"phlex","purl":"pkg:gem/phlex","ranges":[">=1.10.0 <1.10.2"],"fixed":["1.10.2"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}