{"cve":"CVE-2024-31869","nvd":{"published":"2024-04-18T08:15:38.037","modified":"2026-06-17T07:28:52.267","status":"Modified","description":"Airflow versions 2.7.0 through 2.8.4 have a vulnerability that allows an authenticated user to see sensitive provider configuration via the \"configuration\" UI page when \"non-sensitive-only\" was set as \"webserver.expose_config\" configuration (The celery provider is the only community provider currently that has sensitive configurations). You should migrate to Airflow 2.9 or change your \"expose_config\" configuration to False as a workaround. This is similar, but different to  CVE-2023-46288 https://github.com/advisories/GHSA-9qqg-mh7c-chfq  which concerned API, not UI configuration page.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N","score":4.3},"cwes":["CWE-200"],"references":["http://www.openwall.com/lists/oss-security/2024/04/17/10","https://github.com/apache/airflow/pull/38795","https://lists.apache.org/thread/pz6vg7wcjk901rmsgt86h76g6kfcgtk3","http://www.openwall.com/lists/oss-security/2024/04/17/10","https://github.com/apache/airflow/pull/38795"],"products":["apache:airflow"],"source":"nvd","synced_at":"2026-10-19T21:49:08.435428910+00:00"},"epss":{"cve":"CVE-2024-31869","score":0.01058,"percentile":0.64488,"date":"2026-11-01"},"kev":null,"osv":[{"id":"GHSA-2522-mrjc-m688","url":"https://osv.dev/vulnerability/GHSA-2522-mrjc-m688","summary":"Apache Airflow: Sensitive configuration for providers displayed when \"non-sensitive-only\" config used","modified":"2026-07-07T17:56:47.719774081Z","packages":[{"ecosystem":"PyPI","name":"apache-airflow","purl":"pkg:pypi/apache-airflow","ranges":[">=2.7.0 <2.9.0"],"fixed":["2.9.0"]}]},{"id":"PYSEC-2026-1128","url":"https://osv.dev/vulnerability/PYSEC-2026-1128","summary":"Apache Airflow: Sensitive configuration for providers displayed when \"non-sensitive-only\" config used","modified":"2026-07-07T17:56:47.719774081Z","packages":[{"ecosystem":"PyPI","name":"apache-airflow","purl":"pkg:pypi/apache-airflow","ranges":[">=2.7.0 <2.9.0"],"fixed":["2.9.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}