{"cve":"CVE-2024-31621","nvd":{"published":"2024-04-29T17:15:19.057","modified":"2026-06-17T07:28:38.823","status":"Analyzed","description":"An issue in FlowiseAI Inc Flowise v.1.6.2 and before allows a remote attacker to execute arbitrary code via a crafted script to the api/v1 component.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:L","score":7.6},"cwes":["CWE-94"],"references":["https://flowiseai.com/","https://www.exploit-db.com/exploits/52001","https://flowiseai.com/","https://www.exploit-db.com/exploits/52001"],"products":["flowiseai:flowise"],"source":"nvd","synced_at":"2026-10-19T21:49:08.435428910+00:00"},"epss":{"cve":"CVE-2024-31621","score":0.59867,"percentile":0.99132,"date":"2026-11-01"},"kev":null,"osv":[{"id":"GHSA-6wp6-22x5-rr3w","url":"https://osv.dev/vulnerability/GHSA-6wp6-22x5-rr3w","summary":"Flowise vulnerable to code injection via api/v1","modified":"2024-08-02T16:27:07.173138Z","packages":[{"ecosystem":"npm","name":"flowise","purl":"pkg:npm/flowise","ranges":["<1.8.1"],"fixed":["1.8.1"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}