{"cve":"CVE-2024-29203","nvd":{"published":"2024-03-26T14:15:08.747","modified":"2026-06-17T07:22:37.320","status":"Analyzed","description":"TinyMCE is an open source rich text editor. A cross-site scripting (XSS) vulnerability was discovered in TinyMCE’s content insertion code.  This allowed `iframe` elements containing malicious code to execute when inserted into the editor.  These `iframe` elements are restricted in their permissions by same-origin browser protections, but could still trigger operations such as downloading of malicious assets. This vulnerability is fixed in 6.8.1.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","score":6.1},"cwes":["CWE-79"],"references":["https://github.com/tinymce/tinymce/commit/bcdea2ad14e3c2cea40743fb48c63bba067ae6d1","https://github.com/tinymce/tinymce/security/advisories/GHSA-438c-3975-5x3f","https://www.tiny.cloud/docs/tinymce/6/6.8.1-release-notes/#new-convert_unsafe_embeds-option-that-controls-whether-object-and-embed-elements-will-be-converted-to-more-restrictive-alternatives-namely-img-for-image-mime-types-video-for-video-mime-types-audio-audio-mime-types-or-iframe-for-other-or-unspecified-mime-types","https://www.tiny.cloud/docs/tinymce/7/7.0-release-notes/#sandbox_iframes-editor-option-is-now-defaulted-to-true","https://github.com/tinymce/tinymce/commit/bcdea2ad14e3c2cea40743fb48c63bba067ae6d1"],"products":["tiny:tinymce"],"source":"nvd","synced_at":"2026-10-19T21:47:51.568503435+00:00"},"epss":{"cve":"CVE-2024-29203","score":0.00713,"percentile":0.5364,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-438c-3975-5x3f","url":"https://osv.dev/vulnerability/GHSA-438c-3975-5x3f","summary":"TinyMCE Cross-Site Scripting (XSS) vulnerability in handling iframes","modified":"2026-09-10T03:50:10.591117659Z","packages":[{"ecosystem":"npm","name":"tinymce","purl":"pkg:npm/tinymce","ranges":["<6.8.1"],"fixed":["6.8.1"]},{"ecosystem":"NuGet","name":"TinyMCE","purl":"pkg:nuget/TinyMCE","ranges":["<6.8.1"],"fixed":["6.8.1"]},{"ecosystem":"Packagist","name":"tinymce/tinymce","purl":"pkg:composer/tinymce/tinymce","ranges":["<6.8.1"],"fixed":["6.8.1"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}