{"cve":"CVE-2024-28862","nvd":{"published":"2024-03-16T00:15:07.570","modified":"2026-06-17T07:21:54.490","status":"Analyzed","description":"The Ruby One Time Password library (ROTP) is an open source library for generating and validating one time passwords. Affected versions had overly permissive default permissions. Users should patch to version 6.3.0. Users unable to patch may correct file permissions after installation.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","score":5.5},"cwes":["CWE-276"],"references":["https://github.com/mdp/rotp/security/advisories/GHSA-x2h8-qmj4-g62f","https://github.com/mdp/rotp/security/advisories/GHSA-x2h8-qmj4-g62f"],"products":["rotp_project:rotp"],"source":"nvd","synced_at":"2026-10-19T21:46:54.846886191+00:00"},"epss":{"cve":"CVE-2024-28862","score":0.00176,"percentile":0.07116,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-x2h8-qmj4-g62f","url":"https://osv.dev/vulnerability/GHSA-x2h8-qmj4-g62f","summary":"ROTP 6.2.2 and 6.2.1 has 0666 permissions for the .rb files.","modified":"2025-12-05T18:51:59.046252Z","packages":[{"ecosystem":"RubyGems","name":"rotp","purl":"pkg:gem/rotp","ranges":[">=6.2.1 <6.3.0"],"fixed":["6.3.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}