{"cve":"CVE-2024-27936","nvd":{"published":"2024-03-21T02:52:22.813","modified":"2026-06-17T07:20:37.910","status":"Analyzed","description":"Deno is a JavaScript, TypeScript, and WebAssembly runtime with secure defaults. Starting in version 1.32.1 and prior to version 1.41.0 of the deno library, maliciously crafted permission request can show the spoofed permission prompt by inserting a broken ANSI escape sequence into the request contents. Deno is stripping any ANSI escape sequences from the permission prompt, but permissions given to the program are based on the contents that contain the ANSI escape sequences. Any Deno program can spoof the content of the interactive permission prompt by inserting a broken ANSI code, which allows a malicious Deno program to display the wrong file path or program name to the user. Version 1.41.0 of the deno library contains a patch for the issue.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N","score":6.5},"cwes":["CWE-150"],"references":["https://github.com/denoland/deno/commit/78d430103a8f6931154ddbbe19d36f3b8630286d","https://github.com/denoland/deno/commit/7e6b94231290020b55f1d08fb03ea8132781abc5","https://github.com/denoland/deno/security/advisories/GHSA-m4pq-fv2w-6hrw","https://github.com/denoland/deno/commit/78d430103a8f6931154ddbbe19d36f3b8630286d","https://github.com/denoland/deno/commit/7e6b94231290020b55f1d08fb03ea8132781abc5"],"products":["deno:deno","deno:deno_runtime"],"source":"nvd","synced_at":"2026-10-19T21:47:51.568503435+00:00"},"epss":{"cve":"CVE-2024-27936","score":0.00943,"percentile":0.61049,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-m4pq-fv2w-6hrw","url":"https://osv.dev/vulnerability/GHSA-m4pq-fv2w-6hrw","summary":"Deno's deno_runtime vulnerable to interactive permission prompt spoofing via improper ANSI stripping","modified":"2026-09-10T03:50:10.601906622Z","packages":[{"ecosystem":"crates.io","name":"deno","purl":"pkg:cargo/deno","ranges":[">=1.32.1 <1.41.0"],"fixed":["1.41.0"]},{"ecosystem":"crates.io","name":"deno_runtime","purl":"pkg:cargo/deno_runtime","ranges":[">=0.103.0 <0.147.0"],"fixed":["0.147.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}