{"cve":"CVE-2024-27935","nvd":{"published":"2024-03-21T02:52:22.627","modified":"2026-06-17T07:20:37.790","status":"Analyzed","description":"Deno is a JavaScript, TypeScript, and WebAssembly runtime. Starting in version 1.35.1 and prior to version 1.36.3, a vulnerability in Deno's Node.js compatibility runtime allows for cross-session data contamination during simultaneous asynchronous reads from Node.js streams sourced from sockets or files. The issue arises from the re-use of a global buffer (BUF) in stream_wrap.ts used as a performance optimization to limit allocations during these asynchronous read operations. This can lead to data intended for one session being received by another session, potentially resulting in data corruption and unexpected behavior. This affects all users of Deno that use the node.js compatibility layer for network communication or other streams, including packages that may require node.js libraries indirectly. Version 1.36.3 contains a patch for this issue.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:L","score":8.3},"cwes":["CWE-488"],"references":["https://github.com/denoland/deno/commit/3e9fb8aafd9834ebacd27734cea4310caaf794c6","https://github.com/denoland/deno/issues/20188","https://github.com/denoland/deno/security/advisories/GHSA-wrqv-pf6j-mqjp","https://github.com/denoland/deno/commit/3e9fb8aafd9834ebacd27734cea4310caaf794c6","https://github.com/denoland/deno/issues/20188"],"products":["deno:deno"],"source":"nvd","synced_at":"2026-10-19T21:47:51.568503435+00:00"},"epss":{"cve":"CVE-2024-27935","score":0.00722,"percentile":0.54011,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-wrqv-pf6j-mqjp","url":"https://osv.dev/vulnerability/GHSA-wrqv-pf6j-mqjp","summary":"Deno's Node.js Compatibility Runtime has Cross-Session Data Contamination","modified":"2026-09-10T03:50:10.914087690Z","packages":[{"ecosystem":"crates.io","name":"deno","purl":"pkg:cargo/deno","ranges":[">=1.35.1 <1.36.3"],"fixed":["1.36.3"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}