{"cve":"CVE-2024-26143","nvd":{"published":"2024-02-27T16:15:46.800","modified":"2026-06-17T07:17:11.337","status":"Analyzed","description":"Rails is a web-application framework. There is a possible XSS vulnerability when using the translation helpers in Action Controller. Applications using translation methods like translate, or t on a controller, with a key ending in \"_html\", a :default key which contains untrusted user input, and the resulting string is used in a view, may be susceptible to an XSS vulnerability. The vulnerability is fixed in 7.1.3.1 and 7.0.8.1.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","score":6.1},"cwes":["CWE-79"],"references":["https://discuss.rubyonrails.org/t/possible-xss-vulnerability-in-action-controller/84947","https://github.com/rails/rails/commit/4c83b331092a79d58e4adffe4be5f250fa5782cc","https://github.com/rails/rails/commit/5187a9ef51980ad1b8e81945ebe0462d28f84f9e","https://github.com/rails/rails/security/advisories/GHSA-9822-6m93-xqf4","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/actionpack/CVE-2024-26143.yml"],"products":["rubyonrails:rails"],"source":"nvd","synced_at":"2026-10-19T21:45:59.823092188+00:00"},"epss":{"cve":"CVE-2024-26143","score":0.01034,"percentile":0.63858,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-9822-6m93-xqf4","url":"https://osv.dev/vulnerability/GHSA-9822-6m93-xqf4","summary":"Rails has possible XSS Vulnerability in Action Controller","modified":"2026-06-08T23:45:17.847969876Z","packages":[{"ecosystem":"RubyGems","name":"actionpack","purl":"pkg:gem/actionpack","ranges":[">=7.0.0 <7.0.8.1"],"fixed":["7.0.8.1"]},{"ecosystem":"RubyGems","name":"actionpack","purl":"pkg:gem/actionpack","ranges":[">=7.1.0 <7.1.3.1"],"fixed":["7.1.3.1"]},{"ecosystem":"RubyGems","name":"rails","purl":"pkg:gem/rails","ranges":[">=7.0.0 <7.0.8.1"],"fixed":["7.0.8.1"]},{"ecosystem":"RubyGems","name":"rails","purl":"pkg:gem/rails","ranges":[">=7.1.0 <7.1.3.1"],"fixed":["7.1.3.1"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}