{"cve":"CVE-2024-23818","nvd":{"published":"2024-03-20T18:15:09.510","modified":"2026-06-17T07:13:40.157","status":"Analyzed","description":"GeoServer is an open source software server written in Java that allows users to share and edit geospatial data. A stored cross-site scripting (XSS) vulnerability exists in versions prior to 2.23.3 and 2.24.1 that enables an authenticated administrator with workspace-level privileges to store a JavaScript payload in the GeoServer catalog that will execute in the context of another user's browser when viewed in the WMS GetMap OpenLayers Output Format.  Access to the WMS OpenLayers Format is available to all users by default although data and service security may limit users' ability to trigger the XSS. Versions 2.23.3 and 2.24.1 contain a patch for this issue.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N","score":4.8},"cwes":["CWE-79"],"references":["https://github.com/geoserver/geoserver/commit/4557a832eed19ec18b9753cb97e8aa85269741d2","https://github.com/geoserver/geoserver/commit/a26c32a469ee4c599236380452ffb4260361bd6f","https://github.com/geoserver/geoserver/pull/7174","https://github.com/geoserver/geoserver/security/advisories/GHSA-fcpm-hchj-mh72","https://osgeo-org.atlassian.net/browse/GEOS-11153"],"products":["geoserver:geoserver"],"source":"nvd","synced_at":"2026-10-19T21:47:51.568503435+00:00"},"epss":{"cve":"CVE-2024-23818","score":0.00426,"percentile":0.36882,"date":"2026-11-01"},"kev":null,"osv":[{"id":"GHSA-fcpm-hchj-mh72","url":"https://osv.dev/vulnerability/GHSA-fcpm-hchj-mh72","summary":"GeoServer's WMS OpenLayers Format vulnerable to Stored Cross-Site Scripting (XSS)","modified":"2026-09-10T03:50:10.590621033Z","packages":[{"ecosystem":"Maven","name":"org.geoserver:gs-wms","purl":"pkg:maven/org.geoserver/gs-wms","ranges":["<2.23.3"],"fixed":["2.23.3"]},{"ecosystem":"Maven","name":"org.geoserver:gs-wms","purl":"pkg:maven/org.geoserver/gs-wms","ranges":[">=2.24.0 <2.24.1"],"fixed":["2.24.1"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}