{"cve":"CVE-2024-23538","nvd":{"published":"2024-03-29T15:15:10.543","modified":"2026-06-17T07:13:08.503","status":"Modified","description":"Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Apache Fineract.This issue affects Apache Fineract: <1.8.5.\n\nUsers are recommended to upgrade to version 1.8.5 or 1.9.0, which fix the issue.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","score":9.8},"cwes":["CWE-89"],"references":["http://www.openwall.com/lists/oss-security/2024/03/29/2","https://cwiki.apache.org/confluence/display/FINERACT/Apache+Fineract+Security+Report","https://lists.apache.org/thread/by32w2dylzgbqm5940x3wj7519wolqxs","http://www.openwall.com/lists/oss-security/2024/03/29/2","https://cwiki.apache.org/confluence/display/FINERACT/Apache+Fineract+Security+Report"],"products":["apache:fineract"],"source":"nvd","synced_at":"2026-10-19T21:47:51.568503435+00:00"},"epss":{"cve":"CVE-2024-23538","score":0.01291,"percentile":0.70268,"date":"2026-10-31"},"kev":null,"osv":[],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}